How to remove plus addressing?

webstyler

Well-Known Member
Nov 20, 2003
478
3
168
Hello
we have migrate accounts from old to new server
New account have all "creation of plus addressing directory" enable.

We need to remove this.

We have disable "automatically creation from cpanel user" but email still delivered with plus addressing.

Ex. info+sp*[email protected]

we need to deliver to [email protected], for customer that use pop3

So, how to disable plus addressing?

Thanks
 
Last edited by a moderator:

HostNoc

Well-Known Member
Feb 20, 2020
157
39
28
Ontario
cPanel Access Level
Root Administrator
Hi

  1. Log in to the cPanel account that owns the domain/email account you want to disable this feature on.
  2. Navigate to Email Accounts.
  3. Click on MANAGE, next to the email account you want to disable folder creation on.
  4. Under the PLUS ADDRESSING heading, click on the Do Not Automatically Create Folders radio button.
  5. Click the UPDATE EMAIL SETTINGS button.
Regards
 
  • Like
Reactions: cPRex

webstyler

Well-Known Member
Nov 20, 2003
478
3
168
We migrate account from old to new server
After migration we see the flag "automatically create plus addressing" is "on".
The next email received from mailbo user's flagged as sp*m was delivered to sp*m directory on the mailbox
we have disable the flag "automatically create plus addressing"
after this we check exim_mainlog, where we see that email tagged as sp*m still delivered to [email protected]

we check on var/log/exim_mainlog
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,497
1,968
363
cPanel Access Level
Root Administrator
Thanks for the additional details. I wouldn't expect that to happen if the plug addressing is disabled, so it might be best to submit a ticket to our team so we can check the system directly for issues. If you're able to do that, can you post the ticket number here so I can follow along?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,497
1,968
363
cPanel Access Level
Root Administrator
Thanks for that - we replied with the following details:

Code:
Both the plus addressing and spam box features can be enabled. While I do see that the messages were delivered to export+spam on the server, it is unclear as to why this occurred since you've disabled the plus addressing. In most cases these two features should work together as expected
Code:
We do have API calls to enable and disable these settings, however they apply to single addresses not the entire server:
 
https://api.docs.cpanel.net/openapi/cpanel/operation/disable_mailbox_autocreate/
https://api.docs.cpanel.net/openapi/cpanel/operation/enable_mailbox_autocreate/
 
It may be possible to create a loop to apply this to all email addresses on the server but we do not have a specific command that will do this. The following API command will list all email accounts for a user:
 
https://api.docs.cpanel.net/openapi/whm/operation/list_pops_for/