Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to remove tomcat7 from easyapache4?

Discussion in 'EasyApache' started by Joe Mc, Dec 3, 2018.

Tags:
  1. Joe Mc

    Joe Mc Registered

    Joined:
    Dec 3, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Hello,
    I have a Cent Os ver 6 and upgraded to Cloud linux ver 6.1
    I install cpanel ver 76.0.9
    Last months a go I have easy apache 3 and configure with tomcat 7 and I upgraded to easy apache 4 without any problem
    After cpanel ver 76 my tomcat service is stoped and many jvm-* error log created on /tmp folder and full after 1 day and crash the server.
    I googled and see for easy apache 4 release tomcat 8.5 and very different from tomcat 7
    I provision easy apache 4 with tomcat 8.5 but don not help me and tomcat service is stoped ( Also I can not remove tomcat 7 )
    I uninstall tomcat 8.5 with easy apache 4 and uninstall tomcat7 with 2 command line:
    yum remove easy-tomcat7
    yum remove java

    All error is solved but now I have other problem. When I want to update cpanel I have this error:

    [2018-12-01 07:14:24 -0500] ***** FATAL: Test install failed: error: Failed dependencies:
    [2018-12-01 07:14:24 -0500] jakarta-commons-dbcp is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] jakarta-commons-pool is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] java-1.7.0-openjdk-devel is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] log4j is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] java-1.7.0-openjdk >= 1:1.7.0 is needed by easy-jakarta-commons-daemon-1.0.15-1.x86_64
    [2018-12-01 07:14:24 -0500] jakarta-taglibs-standard >= 0:1.1 is needed by easy-tomcat7-webapps-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] ecj >= 4.2.1 is needed by easy-tomcat7-lib-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] jakarta-commons-dbcp is needed by easy-tomcat7-lib-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] jakarta-commons-pool is needed by easy-tomcat7-lib-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] java-1.7.0-openjdk >= 1.7.0 is needed by easy-mysql-connector-java-5.1.25-1.noarch
    [2018-12-01 07:14:24 -0500] The Administrator will be notified to review this output when this script completes
    [2018-12-01 07:14:24 -0500] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
    [2018-12-01 07:14:24 -0500] jakarta-commons-dbcp is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] jakarta-commons-pool is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] java-1.7.0-openjdk-devel is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] log4j is needed by easy-tomcat7-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] java-1.7.0-openjdk >= 1:1.7.0 is needed by easy-jakarta-commons-daemon-1.0.15-1.x86_64
    [2018-12-01 07:14:24 -0500] jakarta-taglibs-standard >= 0:1.1 is needed by easy-tomcat7-webapps-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] ecj >= 4.2.1 is needed by easy-tomcat7-lib-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] jakarta-commons-dbcp is needed by easy-tomcat7-lib-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] jakarta-commons-pool is needed by easy-tomcat7-lib-0:7.0.42-3.noarch
    [2018-12-01 07:14:24 -0500] java-1.7.0-openjdk >= 1.7.0 is needed by easy-mysql-connector-java-5.1.25-1.noarch

    Please help me to fix this error and remove tomcat7

    Thank you
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,423
    Likes Received:
    1,959
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Joe Mc,

    Can you open a support ticket so we can take a closer look at which RPMs are installed on the system? You can post the ticket number here and we'll link this thread to it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice