Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to see web without domain

Discussion in 'General Discussion' started by chencho, Jan 13, 2011.

  1. chencho

    chencho Member

    Joined:
    Oct 5, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    I need to work into a web wich is currently in another server.

    I want to create the account into my server, work into it and when it's finally move the domain.

    The problem is when i try to see the web using http://ip/~user or http://ip/~user/ or http://ip/~user/public_html/ or...

    I have always 404 error
     
  2. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    DataCenter Provider
    The correct access method is:

    http://x.x.x.x/user

    Where x.x.x.x is your account's IP address.

    You host (if you are a reseller or shared) may have disabled mod_userdir which provides this functionality. You may want to ask them if they have done so. Even if you have full root access they may have disabled it on your behalf for security reasons.

    If you do have full WHM access, you can re-enable it at Main >> Security Center >> Apache mod_userdir Tweak.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelJared

    cPanelJared Technical Analyst

    Joined:
    Feb 25, 2010
    Messages:
    1,835
    Likes Received:
    21
    Trophy Points:
    143
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    There needs to be a tilde (~) before the username:

    http://x.x.x.x/~user

    The tilde is what tells Apache "mod_userdir is in use and I need to look for the home directory of the user that follows" instead of simply looking for a directory named "user" (for example) in Apache's document root.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. kduvall

    kduvall Member

    Joined:
    Nov 24, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    Atlanta, GA
    On my server, and on every other cPanel/WHM server I've worked on, the correct access URL is http://x.x.x.x/~user

    I assume there's a place to change that.. or maybe /user was used on older versions of cPanel and was left that way when the server was upgraded for backwards compatibility reasons.

    Either way, if /~user doesn't work, try /user and make sure the feature is enabled in WHM.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    DataCenter Provider
    Whoops, thanks for catching my typo :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. chencho

    chencho Member

    Joined:
    Oct 5, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    Hi all.

    I need to switch off mod_userdir Protection to enable it.

    The option "exclude protection" dont work :(
     
  7. itsmewahab

    itsmewahab Registered

    Joined:
    Oct 18, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Hello,

    You may need to exclude "DefaultHost (nobody)" with your username from Apache mod_userdir Tweak.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice