How to set CHMOD permissions automatically?

Galanthus

Well-Known Member
Nov 8, 2013
87
0
6
cPanel Access Level
Root Administrator
Hi guys,

I am almost finished setting up my FTP settings. But i have a problem. When i create an account in WHM the directory permissions are set to "542 543"how can i set this to 755? and to files like 644?

Because some sites wont work with these permissions. So instead of having to change it manually how can i fix this?

Thanks in advance!

Currently using: proFTPD
 

iserversupport

Well-Known Member
Nov 4, 2013
92
0
56
India
cPanel Access Level
Root Administrator
You can correct the permission automatically for files using the command

- removed -

Make sure to tun it inside the folder public_html after ssh into the server

- - - Updated - - -

To fix the permission of folders you can use

- removed -

Make sure to run it inside /home/username/public_html/
 
Last edited by a moderator:

Galanthus

Well-Known Member
Nov 8, 2013
87
0
6
cPanel Access Level
Root Administrator
You can correct the permission automatically for files using the command

- removed -

Make sure to tun it inside the folder public_html after ssh into the server

- - - Updated - - -

To fix the permission of folders you can use

- removed -

Make sure to run it inside /home/username/public_html/
Hi sir!

Thank you very much as always you are helpful. I only need to ask you how i can set this to GLOBAL settings? so for each account which s created that will have this permissions 755 and 644?
 

Galanthus

Well-Known Member
Nov 8, 2013
87
0
6
cPanel Access Level
Root Administrator
You can correct the permission automatically for files using the command

- removed -

Make sure to tun it inside the folder public_html after ssh into the server

- - - Updated - - -

To fix the permission of folders you can use

- removed -

Make sure to run it inside /home/username/public_html/
F*** i made a mistake i did 644 in ROOT? how can i return this action?