Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to set email correctly

Discussion in 'E-mail Discussion' started by Shchaneric, May 1, 2017.

Tags:
  1. Shchaneric

    Shchaneric Registered

    Joined:
    Apr 30, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hong Kong
    cPanel Access Level:
    Root Administrator
    Hello,

    I am new to cPanel. My situation :

    1. I have a Hostus VPS with WHM/cPanel
    2. My VPS have 1 IP only, so I had disable the Nameserver service in WHM
    3. All of the domain are using other DNS Server which provided by the domain register and pointing to my VPS/WHM IP, such as www, ftp , mail ....
    4. I had setup a rDNS in Hostus, it seem running correctly

    The web, FTP all are running prefectly, but the mail server have problem.

    I had set DNS records and DKIM(cpanel -DNS Check Passsed) & SPF(cpanel - Warning: cPanel is unable to verify that this server is an authoritative nameserver for “my doamin”.) in the domain register's DNS.

    I added the mail account to outlook, it can receive email from gmail, hotmail, my company exchange... , but I cannot send email outbound, only can send inbound.

    In the Mail Queue Manager, the error is "R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out"

    Should I need to fix the SPF warning? Is the DNS records not correct? How to make it run correctly?

    Please help, thanks very much.
     
  2. Shchaneric

    Shchaneric Registered

    Joined:
    Apr 30, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hong Kong
    cPanel Access Level:
    Root Administrator
    Oh, I got the problem, my VPS provider blocked port 25.

    I enabled the EXIM use other port 576. But there are other problem, all of the outbound mail defer due to "R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out"

    How to fix it? Thanks very much
     
  3. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    834
    Likes Received:
    29
    Trophy Points:
    178
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Exim requires port 25 to work - other mail servers are going to use this port to communicate when you send/receive email. So having it blocked and changing the port it listens on is not going to resolve this for you. Doing so only facilitates end users that have port 25 blocked through their ISP that need another port to use for connections to your server. You will either need to contact your provider, or see if using an SMTP relay like SendGrid is possible instead.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,826
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    The previous post is correct. There's an additional thread on this topic at:

    change port 25

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice