The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to setup default main website then 3 others on VPS

Discussion in 'General Discussion' started by pc-addict, Feb 26, 2013.

  1. pc-addict

    pc-addict Registered

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi, I'm in the process of changing from shared reseller hosting to VPS and completely new to WHM.

    So far I've setup my name servers, named my hostname, setup dns zone setup features and packages, added the main website account, setup ftp, uploaded main site to home/user/public_html but currently my domain displays cgi-sys/defaultwebpage.cgi,

    I cant figure out what needs to be done next, how do I get my main site working?

    I've also changed the the default website page in the Web Template Editor too but doesnt do anything

    Also in the Basic cPanel Whm setup there is a box to change the default home directory, I'd like the directory to be home/sites/ but when i change this and then try to create an account there is an error saying cannot create account home/sites/ directory not found, I've tried to create this directory through ftp program but this way doesnt give me permission, how do i create this default directory?

    Thanks for any help....
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator

    There is not such a things as "main website account" in a cPanel server.
    If your server's hostname is like host.yourdomain.com, and you create an account for the domain yourdomain.com, you can call it "main website acount", but after all it is just like any other account in the server.

    If the site shows cgi-sys/defaultwebpage.cgi it's most likely a propagation or caching issue and will get fixed by itself after a while.




    I'd suggest you leave that setting as it is.
     
  3. pc-addict

    pc-addict Registered

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Many thanks for your speedy reply and assistance,

    I'll wait a couple of days for propagation and leave the default directory as recommended.
     
  4. pc-addict

    pc-addict Registered

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    A few days has passed now and still no change.....

    http://www.mydomain/cgi-sys/defaultwebpage.cgi is still showing

    As the domain is working I would imagine this illuminates a Nameserver or DNS misconfiguration and must be an issue the WHM not linking to the newly created account of the public_html directory

    does anyone know what the problem might be?
     
    #4 pc-addict, Mar 4, 2013
    Last edited: Mar 4, 2013
  5. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    A few things I would check:

    Does that domain have correct name servers?
    Do those name servers point to your server?
    Is there a DNS Zone for that domain in your server?
    Does the domain resolve to the IP address of your server?
    Is there a VirtualHost entry in /usr/local/apache/conf/httpd.conf, and if there is, is DocumentRoot correct?
    Is there an error in /usr/local/apache/logs/error_log when you try to access the site?
     
Loading...

Share This Page