The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to stop bandwidth logging on high traffic server?

Discussion in 'General Discussion' started by racakg, Jul 8, 2010.

  1. racakg

    racakg Member

    Joined:
    May 17, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Hello, I have high traffic server with only one account. I want to completely stop bandwidth logging because cpanellogd proccessing my bandwidth log unnecessary (every 8 hours) and use high CPU utilization for a couple of minutes.

    I use cPanel 11.25.0-S46156 - WHM 11.25.0 with Piped Log enabled.

    What should i do?
     
  2. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    WHM -> Tweak settings -> you can disable all stats packages there.
     
  3. racakg

    racakg Member

    Joined:
    May 17, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for you answer eth00.

    Can you please be more specific, what should i have to check/uncheck there?

    In "Stats Programs" all is unchecked already.
     
  4. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    In order to do this, I believe you'll need to black out all the stats processing hours. In WHM > Statistics Software Configuration area, click on the button on the far bottom right of "Configure Statistic Process Time Schedule", then check every single hour of the day in the new screen under "Statistics Processing Times" and click the Save button.

    Now, I'm wondering if you change the "Process bandwidth every 2 hours." area back in Statistics Software Configuration area to 0, if that would mean it never runs? I've never tried to shut down bandwidth, so you might try changing that to either a really high number or 0 to see the results. Blocking out every hour of the day from stats processing should conceivably prevent it from processing any stats (bandwidth and log files).
     
  5. racakg

    racakg Member

    Joined:
    May 17, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I was check every single hour of the day under "Statistics Processing Times" and set "Process bandwidth every 8 hours" but bandwidth is still processing every 8 hours.

    I am not shure what will happen if I set "Process bandwidth every 0 hours". This is high traffic server (10TB montly traffic) and I am afraid to make unsuspected error.
     
  6. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    I didn't just mention 0, I alternatively suggested a very high number (8 wouldn't be a really high number). Try instead to put like 999, which is 41 days.
     
  7. racakg

    racakg Member

    Joined:
    May 17, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ok, but what should I expect after 41 days with CPU when bandwidth processing start? I am afraid of all day bandwidth processing then.
     
  8. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    Hopefully, you would have opened a ticket within that timeframe to ask how to properly get the bandwidth stopped, since checking every hour to stop bandwidth processing should have stopped it. I am still uncertain why it would process bandwidth when you have every day blocked off from having it processed.

    To open a ticket, go to WHM > Support Center > Contact cPanel for that. Also, once you do have the issue resolved, if you could reply back here on this thread to let us know how it was finally fixed to stop bandwidth processing for your machine.
     
  9. hackboys

    hackboys Active Member

    Joined:
    Feb 12, 2008
    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    8
    Hello,

    In order to stop bandwidth logging, you will need to remove all Bandmin related crons for the root user, you will also need to disable Bandmin from running on boot:

    chkconfig --del bandmin

    After this, you will need to stop Bandmin:

    /usr/local/bandmin/bandminstop

    This should disable bandwidth logging
     
Loading...

Share This Page