The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to stop bounced spam to non-existant users

Discussion in 'General Discussion' started by matt621, Nov 18, 2003.

  1. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    What happens is that several of our customers have changed their email addresses due to their primary one being overwhelmed by spam.

    But the spam just keeps coming.

    And when it does not find an account on our clients domain, it bounced to our mail queue, which fills up very fast.

    they are from spammer, to "X-Failed-Recipients:"

    They are usually to either

    Mailer-Daemon@server.ourdomain.com or msd_id@server.ourdomain.com

    we also have some sent to blah@server.ourdomain.com

    how do we get rid of this junk?

    Also, spam assissinator files up the mail queue. For some reason, mail that it identifies as spam doens't make it to the user.. that's great, but instead it goes to the mail queue. how do we just get rid of them?

    Thanks.
     
    #1 matt621, Nov 18, 2003
    Last edited: Nov 18, 2003
  2. dadman

    dadman Member

    Joined:
    Sep 7, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kansas
    ":blackhole:"

    Use WHM to set any mail to an unknown recipiant to :blackhole: and it's deleted.

    Andy
     
  3. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
  4. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    if you set the email address with @domain.com to :blackhole:
    then all email at :blackhole:mad:yourdomain.com that does not have a POP3 email account will be removed.

    example spam email sent to mailbox blah@domain.com
    if @domain.com has a blackhole setup and blah does not exist it will not sit in the mail list it will be removed.

    Basically its your EU's. They have to setup there default email as :blackhole:

    if they dont do that they will cont to get spam thats sent to false email addresses on there domain.

    example 2

    if blackhole is setup and setup correctly and your getting spam from a valid email address (one that actually exists)

    you can have cPanel block out whole headers.

    just goto Mail Manager then to Block Email address then goto Add Filter.

    and you can block out headers of these spam messages.

    Hope this info helps.
     
  5. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    Sorry, but it doesn't help.

    This sever is known as server.ourdomain.com (this is our 3rd server)

    but the site ourdomain.com is on another server. (our 2nd server.)

    The problem is there is no account "server.ourdomain.com" to set default addresses for.
     
  6. dadman

    dadman Member

    Joined:
    Sep 7, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kansas
    It Still has Exim runnibg!

    Set the emails to blackhole and it should remove them anyway. If not, block the IP they are coming from or filter it with Exim.

    Andy
     
  7. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    blocking IPs is impossible. there are thousands of them.

    "Filtering?" Like what. Like how?


    I appreciate the help, but none of these answers go the root of the problem.
     
  8. dadman

    dadman Member

    Joined:
    Sep 7, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kansas
    A few options on filters!

    Set up Spamassisin with WHM and enable it via Cpanel for the domains. Client side will need to config their mail client to filter the messages with the spamassisin headers.

    You can edit some of the operations directly in Exim, a little trickeir, but very effective, see www.exim.org for more info.

    You said most of the email had similar delivery addresses, client side configs for those will effectively filter the spam as well.

    I hope this helps.

    My guess is that you are missing something in the setup for the blackhole directive or you wouldn't be having the problem!

    Andy
     
Loading...

Share This Page