The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to stop email being sent as local to the cpanel account

Discussion in 'E-mail Discussions' started by danielshaw007, Oct 23, 2014.

  1. danielshaw007

    danielshaw007 Registered

    Joined:
    Oct 23, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi all

    Got a slight issue with my hosting account that I have with CrazyDomains.. I have tried contacting their support but they dont seem to understand the point I am getting at.

    I host multiple websites on 1 account at CrazyDomains.. as luck would have it, 2 of the domains I host want to send email to each other..

    Domain 1 lets say domain1.com has email setup on the cpanel and the website is hosted too.
    Domain 2 lets say domain2.com only has the website hosted and the email is hosted externally to the cpanel using office 365s hosted exchange.

    Domain 1s nameservers point to CrazyDomains and all is ok!
    Domain 2s nameservers do not point to CrazyDomains, just the A record so that the website hosting works.
    Domains 2s MX record is set on the domain control panel and points to the Exchange server and is working ok.

    When Domain 1 tries to send an email to Domain 2.. CrazyDomains cPanel tries to send the email to the local cPanel and of course the email then bounces saying no such user here..

    The million dollar question is how do I get it so that the email from Domain1 to Domain2 gets sent to the external server? I have looked at changing MX records within cPanel but I cant see that option anywhere.

    I hope someone on here understands what I am trying to explain and has a easy solution :)

    Thanks in advance
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please ensure you select "Remote Mail Exchanger" under "Email Routing" via "cPanel - MX Entry" for the domain name with it's email handled by a remote server.

    Thank you.
     
  3. danielshaw007

    danielshaw007 Registered

    Joined:
    Oct 23, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi Michael.. Thanks for that :)

    I have had to email CrazyDomains support for them to do this as they seemed to have taken them options away from the cPanel that I have access to. Is there a way to manually perform this by editing any config files perhaps?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's possible to manually edit the /etc/localdomains and /etc/remotedomains to make this change, but access to those files is restricted to the "root" user.

    Thank you.
     
Loading...

Share This Page