The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to stop exim from reverse lookup check for trusted IPs...

Discussion in 'General Discussion' started by iquest, Jul 6, 2005.

  1. iquest

    iquest Active Member

    Joined:
    Mar 16, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hello Guys,


    My client has been getting the following message in OE, while sending email:

    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'sales@example.com'. Subject 'hi', Account: 'SALES', Server: 'mail.example.net', Protocol: SMTP, Server Response: '550 Administrative prohibition', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC79

    The log shows this:

    2005-07-03 23:10:16 no IP address found for host adsl-156-1-178.bna.bellsouth.net (during SMTP connection from (EAGLE) [70.156.1.178])
    2005-07-03 23:10:16 H=(EAGLE) [70.156.1.178] F=<sales@example.net> rejected RCPT <sales@example.com>: host lookup failed for reverse lookup check (70.156.1.178 does not match any IP address for adsl-156-1-178.bna.bellsouth.net)


    Another client is getting the same error '550 Administrative prohibition' and his log shows this:

    2005-07-05 12:50:56 H=(notebook-pc.2nd_example.com) [202.52.215.125] F=<sales@2nd_example.com> rejected RCPT <info@customers_email.com>: host lookup failed for reverse lookup check (failed to find host name from IP address)


    I checked both of the my clients static IPs - assigned by their ISPs. The first one has no 'A' record defined in the PTR and the second one has no PTR. I think that is the reason why they can not send any emails. I'm using cPanel 10.2.0-C131 and CentOS 3.5 with EXIM 4.51.

    This issue can be resolved by unchecking the option "Verify the existance of email senders" from WHM by selecting the options of "Exim Configuration Editor".

    I tried the following setup in - '/etc/exim.conf' and restarted exim:

    Code:
    hostlist relay_hosts = lsearch;/etc/relayhosts : \
        localhost : 70.156.1.178 : 202.52.215.125
    It didn't work. I was wondering if there are any other solutions to fix this issue other than unchecking the option: "Verify the existance of email senders". Or how can I stop EXIM from checking reverse IP lookup for these two IPs?

    Thank you in advace for your cooperation...
     
  2. nisse

    nisse Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    It looks like you've got reverse_host_lookup verification enabled somewhere in your RCPT ACL. You can either disable it or add
    !hosts = +relay_hosts as a condition.
     
  3. iquest

    iquest Active Member

    Joined:
    Mar 16, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hi nisse - thank you for your reply. I already have the setting "!hosts = +relay_hosts" in my setup and also have reverse lookup enabled (require verify = reverse_host_lookup). But I think that this issue is not related to these settings since I tried to disable the reverse lookup or even all the custom settings I made but the result is same. The irnoy is that the client can send email using another ISP. He can not send any email using his own ISP, who assigned him a static IP. And the IP has no PTR record. It is probably related to cPanel's reverse lookup check, which can be enabled through WHM. There has to be a way to disable reverse checking on these IPs or list these IPs as trusted. I still couldn't figure out how to do that. I hope that you can give me some lead on this...
     
  4. nisse

    nisse Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    What happens if you comment out require verify = reverse_host_lookup?
     
  5. iquest

    iquest Active Member

    Joined:
    Mar 16, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1

    Thanks for your reply. I already mentioned in my earlier post that I tried it and the result is same. I even tried it with exim default setup in the exim.conf file and commented out all the changes I made but the result is same. The client can only login - if I uncheck the option "Verify the existance of email senders" from WHM. Any idea how to keep this option enabled and make these IPs - trusted host?
     
Loading...

Share This Page