The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to stop SPAM from being forwarded

Discussion in 'General Discussion' started by WK-Anthony, Apr 11, 2006.

  1. WK-Anthony

    WK-Anthony Member

    Joined:
    Dec 10, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I've hit an annoying problem. We just developped an in-house alerting system which uses forwarders in order to keep a message on the server..

    Now, we get messages ticketed as SPAM (by SpamAsassin level 4.0) forwarded as well.

    Is there a way to stop this from happening?
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    I'm pretty sure if you turn on the spam box it won't be forwarded.
     
  3. WK-Anthony

    WK-Anthony Member

    Joined:
    Dec 10, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hmmmm...SB is enabled (spam folders within Horde)
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    I'd just like to clarify a couple of things.

    If you set up an email filter, mail will be parsed by SA and then delivered per the filter rules. I've noticed that, from having a filter piping mail to a PHP script, spam will still end up reaching the script.

    However if you use a forwarder, mail will be properly checked and spam will get filtered out with only legitimate mail being forwarded on.

    Perhaps it's just me, but that's the behaviour I've observed.

    Just on the off-chance that you're using a filter and not a forwarder, make sure you switch to a forwarder instead.
     
Loading...

Share This Page