Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to turn off ident ?

Discussion in 'E-mail Discussion' started by sneader, Nov 21, 2008.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,155
    Likes Received:
    39
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    My logs are filled with ident messages like:

    2008-11-21 12:40:38 [3935] SMTP connection from [123.123.123.123]:57340 I=[72.72.72.72]:25 (TCP/IP connection count = 1)
    2008-11-21 12:40:40 [16563] ident connection to 123.123.123.123 timed out

    Why does Exim even bother to try idents, when hardly anybody responds to them anymore? Seems like a waste of resources.

    If you agree, then Jane, how do I stop this crazy thing? :)

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    769
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    /dev/null
    According to the exim docs, setting the config option rfc1413_query_timeout to 0s turns off ident.

    Code:
    rfc1413_query_timeout = 0s
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,155
    Likes Received:
    39
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Thanks Nick, that is cool!

    I see that this is not editable within the Exim Configuration Editor (it's not in an editable section)... so the next time I make an Exim edit, or Exim gets upgraded, I will lose the change.

    But I've made the change, and it's definitely working. I bet there isn't much chatter about this problem, because Exim doesn't log this by default, you have to turn on more verbose logging to see all these ident timeouts.

    I have "log_selector = +all" entered in the first editable box in the Exim Configuration editor, to give me more verbose Exim logging, which I really like when troubleshooting. That starts showing all the ident timeouts.

    Thanks again for taking time to find that fix for me -- much appreciated!

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,155
    Likes Received:
    39
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I've entered a feature request in Bugzilla, to ask for the ability to edit this portion of /etc/exim.conf, so that we can enable/disable Ident Requests without having this change overwritten:

    http://bugzilla.cpanel.net/show_bug.cgi?id=8141

    Feel free to add comments and/or votes.

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice