furquan

Well-Known Member
Jul 27, 2002
473
4
168
Hello :

Apologies to bump an old thread but since i need to upgrade my CLAMAV..i thought of posting to this thread..

When i do a "whereis freshclam" i too get the same message :-

"freshclam: /usr/bin/freshclam /etc/freshclam.conf /usr/local/bin/freshclam /usr/
share/man/man1/freshclam.1"

Hence what do i need to do, to get my clam updated ?

Looking at another thread by "Chirpy" i have deleted all these files from my server :-

HTML:
/bin/rm -Rfv /usr/local/bin/clam*
/bin/rm -Rfv /usr/local/sbin/clam*
/bin/rm -Rfv /usr/local/lib/libclam*
/bin/rm -Rfv /usr/local/share/clam*
/bin/rm -Rfv /usr/local/include/clam*
/bin/rm -Rfv /usr/local/bin/freshclam*
/bin/rm -Rfv /usr/local/etc/clamav*
What next ?

Thank you all.
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
25
143
Houston, TX
cPanel Access Level
Root Administrator
I moved this post to its own thread since the original thread was so old and not likely relevant to the problem you are experiencing. The original thread is here:

http://forums.cpanel.net/f5/clam-av-how-update-31287.html

You can find the location of the freshclam binary by using the which command. Normally it is in /usr/local/bin:

Code:
# which freshclam
/usr/local/bin/freshclam
This is where it is located if it was installed as a cPanel plugin. If you have removed all of the files you mentioned, you may need to remove ClamAV and reinstall it using Main >> cPanel >> Manage Plugins.

Are you experiencing a particular problem or error when you try to update ClamAV?
 

RangeHosting

Member
Jan 21, 2008
10
0
51
I'll jump in here as this seems to relate to a problem I've been having. I've been getting the following emails:
LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq *** LibClamAV Warning: ***********************************************************
And when I login to the server and run freshclam I get the following:
[email protected] [/]# freshclam
ClamAV update process started at Mon Dec 6 20:04:08 2010
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.96.3 Recommended version: 0.96.5
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
Downloading daily-12362.cdiff [100%]
Downloading daily-12363.cdiff [100%]
Downloading daily-12364.cdiff [100%]
LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
daily.cld updated (version: 12364, sigs: 10949, f-level: 58, builder: guitar)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 55, recommended = 58
DON'T PANIC! Read http://www.clamav.net/support/faq
bytecode.cld is up to date (version: 93, sigs: 16, f-level: 54, builder: edwin)
Database updated (857179 signatures) from database.clamav.net (IP: 194.47.250.218)
[email protected] [/]#
Am I doing something wrong or do I just need to wait for cpanel or Clam to update something? I've looked at the FAQ page but am worried that the normal rules don't apply to cPanel systems.

Thanks,

Tom
 
Last edited:

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,544
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
I'll jump in here as this seems to relate to a problem I've been having. I've been getting the following emails:

And when I login to the server and run freshclam I get the following:


Am I doing something wrong or do I just need to wait for cpanel or Clam to update something? I've looked at the FAQ page but am worried that the normal rules don't apply to cPanel systems.

Thanks,

Tom
Please see the following thread: [Case 45094] ClamAV 0.96.3 installed -- latest available is 0.96.5 - cPanel Forums