How to upgrade MySQL to 4.0.18 in FreeBSD4.8?

Jedia

Well-Known Member
Mar 18, 2004
200
0
166
CN
Hello.
my server running freebsd4.8 and whm r27. the mysql is 4.0.10-gamma, it's too old , i have some program could not be running.
i had try to upgrade ports, upgrade fine, i try /scripts/upcp ,but it delete a lot of ports list, and install mysql 4.0.10-gamma for me .
how can i upgrade mysql to 4.0.18 please? download the source file and make it? and how to ..? Thanks:)
 

Jedia

Well-Known Member
Mar 18, 2004
200
0
166
CN
Hi, cpanelben.
i found this file in /var/cpanel
nothing in it. i ran but tal me
./usebsdpkgs: Permission denied.

what's going on? into /usr/ports/databases/mysql40-server
and
make install
?
Thanks
 

webrats

Active Member
Feb 7, 2002
26
0
301
Originally posted by Jedia
Hi, cpanelben.
i found this file in /var/cpanel
nothing in it. i ran but tal me
./usebsdpkgs: Permission denied.

what's going on? into /usr/ports/databases/mysql40-server
and
make install
?
Thanks
cd /usr/ports/databases/mysql40-server
make
make deinstall maybe makeunistall
make reinstall

and your done
 

Jedia

Well-Known Member
Mar 18, 2004
200
0
166
CN
Originally posted by webrats
cd /usr/ports/databases/mysql40-server
make
make deinstall maybe makeunistall
make reinstall

and your done
ok, but when i installd cpanel, the mysql is installd from ports? if yes, upgrade is so easy~, but is not, may i reset the PATH to installd?
 

webrats

Active Member
Feb 7, 2002
26
0
301
Originally posted by Jedia
ok, but when i installd cpanel, the mysql is installd from ports? if yes, upgrade is so easy~, but is not, may i reset the PATH to installd?

cpanel does use ports

if you notice it has an upgrade ports option in whm

im running 4.0.18 just fine

run away from 12 it has many many bugs
18 cut my load by %22