cjsmiff

Registered
Nov 7, 2018
3
0
1
United Kingdom
cPanel Access Level
Root Administrator
Hi,

When installing fileinfo through Easyapache4 it automatically removes mbstring (and various others). All of my client's sites need mbstring installed except for one that can't live without fileinfo installed instead. Does anyone know how I can enable both? Or, how do I enable fileinfo for one Account only? Or, is there another solution that I'm not finding/seeing please?!

Many thanks for your time :)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
Hello @cjsmiff,

I've been unable to reproduce this behavior on a test system:

Code:
# rpm -qa|grep ea-php72-php-mbstring
ea-php72-php-mbstring-7.2.11-2.2.3.cpanel.x86_64

# yum install ea-php72-php-fileinfo

# rpm -qa|grep ea-php72-php-fileinfo
ea-php72-php-fileinfo-7.2.11-2.2.3.cpanel.x86_64
# rpm -qa|grep ea-php72-php-mbstring
ea-php72-php-mbstring-7.2.11-2.2.3.cpanel.x86_64
Can you let me know the specific steps you are using to reproduce this issue? Additionally, can you let me know which version of cPanel & WHM is installed on the system?

Thank you.
 

cjsmiff

Registered
Nov 7, 2018
3
0
1
United Kingdom
cPanel Access Level
Root Administrator
Hi,

I have recently upgraded to WHM & cPanel 76.0.4. (Note: I had this problem with the previous versions too)

In WHM Software-Easyapache4 I am clicking to Customize the cPanel Default package. In PHP Extensions I search for mbstring and enable it for php70 & 71 (see 1st pic below), then I click the Next buttons at the bottom of the page until I reach the Review page. It is on the Review page that I am told this action will uninstall fileinfo (See 2nd pic below) and it actually does uninstall it if I click to Provision it.

- Removed -

Many thanks for your time.
:)
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
Hello @cjsmiff,

It's possible there's some other conflict in-place that I'm not able to reproduce. Can you open a support ticket so we can take a closer look at your system? You can post the ticket number here and we will update this thread with the outcome.

Thank you.
 

cjsmiff

Registered
Nov 7, 2018
3
0
1
United Kingdom
cPanel Access Level
Root Administrator
Hi,

Thank you for your reply. Unfortunately I am not able to create an account to be able to do that as the link to click in the account activation email takes me to a page that says "The key did not match". So, I am unable to complete account activation. Do you know why please?

Many thanks
Claire :)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
Hi @cjsmiff,

Can you open the request as an email sent directly to cs @ cpanel.net? You'll be assigned a ticket number and our CS team can forward the request over to Technical Support so we can determine why you're seeing "The key did not match" when opening a ticket and then proceed to assist you with the EA4 PHP module issue.

Thank you.