The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to use SSL with email ?

Discussion in 'E-mail Discussions' started by Radio_Head, Sep 24, 2003.

  1. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Hello,

    anyone can give some instruction to use SSL with Email
    (to send and receive using SSL) ?

    When on my Eudora I select SSL , I receive the error
    "server doesn't support SSL" .

    I searched on this forum , I found something , but nothing to solve my question .

    Thank you
     
    #1 Radio_Head, Sep 24, 2003
    Last edited: Sep 24, 2003
  2. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Ok I solved with Outlook (thanks to friends on irc) .

    It's easy , you have to edit your email account , and use hostname for smtp and pop3 (instead of mail.domain.com) and then (on advanced) you have to use port 465 for smtp and 995 for pop3 (SSL) .

    I have still to understand how to use ssl email with Eudora 5.1 . Anyone which is able to read and send email using SSL with Eudora can explain the forum how to do ... ?

    Thank you


    (if you want know if your box is able to read and send email with ssl execute this

    https://hostname:465

    you should receive something like this
    220-hostname ESMTP Exim 4.23 #1 Wed, 24 Sep 2003 17:21:27 -0400 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. )
     
    #2 Radio_Head, Sep 24, 2003
    Last edited: Sep 24, 2003
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    ok I found a solution also for Eudora :p !!!!

    ====================================
    HOW to read and send email using SSL and Eudora
    ====================================

    First open your eudora.ini file and add these lines
    SSLPOPAlternatePort = 995
    SSLIMAPAlternatePort = 993
    SSLSMTPAlternatePort = 465

    Save and open Eudora .

    Go on Personalities
    Open a Persona Proprierty
    Replace smtp and pop3 server with your server hostname
    On Secure Socket when Sending select "Required Alternate port"
    On Secure Socket when Receiving select "Required Alternate port"

    Eudora accept SSL connection only if is installed a valid trusted certificate ! So , if your hostname has a valid certificate installed(*) you will receive no error , you will be able to send and receive email .

    If your hostname contains a certificate which is not trusted
    follow this :

    Check email on the email account with SSL .
    Eudora will report you a certificate error.
    Go on Personalities
    Open the Persona with SSL
    Go to Incoming
    Click on Last SSL Info and trus the certificate !
    Ok now you should be able to receive mail with SSL

    To send with SSL
    Send a message with the email account with SSL .
    Eudora will report you a certificate error.
    Go on Personalities
    Open the Persona with SSL
    Click on Last SSL Info (sending) and trust the certificate !
    Ok now you should be able to SEND mail too with SSL


    Bye!


    (*) /etc/exim.crt and /etc/exim.key must contain the same
    certificate of your hostname

    cPanel.net Support Ticket Number:
     
  4. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    After latest cpane update (WHM 8.5.4 cPanel 8.5.4-E8)
    I am no more able to read/send email using SSL

    I receive this error .
    Unknown certificate , chain validation error ?
     
  5. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    I found the problem , also if I have still to solve it .

    My problem is only to receive email because the certificate is expired .

    port 465 required to SEND email with ssl uses /etc/exim.crt and /etc/exim.key as definied on exim.conf

    You can execute
    https://yourhostname:465

    to know the expiration of your certificate to send email with ssl.


    port 995 required to *RECEIVE* email with ssl DOES NOT use /etc/exim.crt and /etc/exim.key !!!
    as I was supposing !

    In fact when I was gone to
    https://yourhostname:995

    to know the expiration of certificate , It was different from the the certificate used on port 465 !

    21 Oct 2003 !!


    Now to solve the problem I have only to know what certificate use port 995 .
     
    #5 Radio_Head, Oct 24, 2003
    Last edited: Oct 24, 2003
  6. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Thanks for sharing your knowledge, Radio_Head.
     
  7. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    It uses the SAME certificate used for cpanel/whm

    The key and crt contained on


    /usr/local/cpanel/etc/cpanel.pem !

    So the problem is easy . To update certificate date on
    /usr/local/cpanel/etc/cpanel.pem it's enought to execute
    Reset cPanel/WHM Certificate with whm !



    @ casey : thank you;)
     
    #7 Radio_Head, Oct 24, 2003
    Last edited: Oct 24, 2003
  8. AlexAT

    AlexAT Well-Known Member
    PartnerNOC

    Joined:
    May 23, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ukraine
    cPanel Access Level:
    Root Administrator
    It's really helpfull.
    Thank you!
     
  9. deftech

    deftech Member

    Joined:
    Jan 11, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    How do you make the certificate not give your email clients an invalid certificate message?

    Eudora works via ssl but comes back and says my certificate is not trusted.

    Also when I goto https://mydomain.com:2087 I get the message:

    This CA Root certificate is not trusted. To enable trust, install this certifacte in the Trusted Root Certification Authorities store.

    Frustrating, because I have a pop3 downloader that won't work because the certificate isn't trusted.
     
Loading...

Share This Page