The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How update older scripts to work with the security token system?

Discussion in 'cPanel Developers' started by mmarulanda, Feb 2, 2012.

  1. mmarulanda

    mmarulanda Member

    Joined:
    Sep 18, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i need update my script, but i don't know how.

    My addon_xxx.cgi is this

    Code:
    #!/usr/bin/perl
    #WHMADDON:xxx:Salo
    # start main
    
    print "Content-type: text/html\n\n";
    print '<meta http-equiv="refresh" content="0;url=/cgi/salo/menu.php"/>' ;
    and all my file are in SALO directory, menu.php, recover.php.

    When i try to open the link in WHM, it say "Access Denied: Security Token Failure".

    How i do to script work fine without dissable Token.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page