The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How we can run run PHP 5.3 and 5.4 in same server without CloudLinux

Discussion in 'CloudLinux' started by 000, Jul 17, 2014.

  1. 000

    000 Well-Known Member

    Joined:
    Jun 3, 2008
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Hi.

    is possible run PHP 5.3 and 5.4 in same server without COULDLINUX ($$$) ???

    How can the only the user ABC run PHP 5.3 ?
    Without we need pay US $15 extra each month ?

    Thanks
     
  2. corporatehost

    corporatehost Member

    Joined:
    Jul 17, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    Hope the following link is useful : /http://www.webhostingtalk.com/showthread.php?t=1107060
    install php 5.2 and 5.3 on cpanel server. - Software & Scripts Offers - Web Hosting Talk
     
  3. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Sorry, no this is not possible without something such as CloudLinux. There is an open Feature Request you should vote on as well.
     
  4. 000

    000 Well-Known Member

    Joined:
    Jun 3, 2008
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    But pay by license of cPanel + licence of CloudLinux
    only to run PHP 5.3 + PHP 5.4
    is wrong method of business from cPanel company...
     
  5. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    It would be if cpanel owned cloudlinux, but they don't.
     
  6. 000

    000 Well-Known Member

    Joined:
    Jun 3, 2008
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Previuslly yes is possible run PHP5.3 + PHP5.4 into cPanel.

    But now they remove this from WHM/EasyApache

    - - - Updated - - -

    What do you think about:

    http://www.nixtree.com/ntphp.php

    ???

    (Free!)
     
  7. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    That is not correct. It was never possible to run two minor versions of PHP (PHP 5.3 and 5.4) on a default cPanel installation, without significant unsupported customization. We have not removed that from EasyApache, because it was never there.

    You may be thinking of PHP 4 and PHP 5, which are two different major versions of PHP. We did remove PHP 4 from EasyApache because it is deprecated.

    It has never been possible to run two minor versions of PHP at once on a cPanel server without CloudLinux or significant unsupported customization. We have not removed that functionality because cPanel never had it.
     
Loading...

Share This Page