Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

HOWTO disable ProFTP on cpanel boxes ...

Discussion in 'General Discussion' started by trakwebster, Jun 29, 2003.

  1. trakwebster

    trakwebster Well-Known Member

    Jan 29, 2003
    Likes Received:
    Trophy Points:
    On our machines, we have no need to run ProFTP or any ftp program. But when I tried to get it turned off I had to struggle a bit, because cpanel kept turning it back on!

    After tinkering, I think I've learned the complete steps to make ProFTP cease to run. Here they are --

    1) To see whether ftp is running, you can use 'ps -aux | grep ftp'.

    To stop proftpd running *now*, run /etc/rc.d/init.d/proftpd stop.

    To verify it's no longer running, again use 'ps -aux | grep ftp'.

    2) There's a checkbox in Service Manager in WHM and it appears to make ProFTP stop running. But it does *not* actually work. This checkbox is effectively broken.

    Because every five minutes, cpanel checks to see that some ftp is running, and if not defaults to proftp and starts it up. End of story. Cannot turn off ProFTP from WHM.

    (It will *appear* to stop, but if you reboot, or if the next cpanel check comes along, proftp will be started up again.)

    3) Removing /etc/rc.d/init.d/proftpd startup script does stop it from running, but generates 288 daily complaining emails from cpanel.

    However, removing this file is the only way to stop proftp after reboots, so it must be removed. If you might *ever* use ftp again, then you'll want to keep this file somewhere.

    4) To stop cpanel's checking (and complaining), you must also remove /etc/chkservd.d/proftpd file. This stops cpanel checking for ftp running. (Likewise, if you might ever use ftp, then you'll want to keep this file somewhere.)

    That's it. ProFTP is now not running, will not start up on reboot, and will not be restarted every five minutes by cpanel.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. M|22

    M|22 Member

    Jun 22, 2003
    Likes Received:
    Trophy Points:
    seems like a pain in the ass, why not just use a firewall to block the ports? Support Ticket Number:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice