The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HOWTO: Show the spam score in the subject line of spam taged messages

Discussion in 'General Discussion' started by cPanelNick, Aug 20, 2007.

  1. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Enter WHM Main >> Service Configuration >> Exim Configuration Editor.

    Change the value for "Text to add to the subject header for messages spamassassin marks as spam."

    to

    Code:
    ***SPAM*** Score:$spam_score

    You could also use $spam_score_int if you do not want to see the decimal value.
     
  2. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Thanks Nick!!! cool deal. You need to cut back on the mind reading though, freaking me out .. I swear I almost asked you about this on phone yesterday!!! that's freaky man :eek:
     
  4. jpmohr

    jpmohr Member

    Joined:
    Jan 25, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Awesome! I have spent hours trying to get "**SPAM (_SCORE_)**" to work, which apparently doesn't work any more! Your solution got it to work for me. Thanks so much for sharing.

    - JPM.
     
  5. FrankyKnife

    FrankyKnife Member

    Joined:
    Mar 27, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zurich (CH)
    Where can i find the option "Text to add to the subject header for messages spamassassin marks as spam" ?

    If i go here (WHM Main >> Service Configuration >> Exim Configuration Editor) there is not such an option. (version: cPanel 11.24.4-R33609 - WHM 11.24.2 - X 3.9)

    thx
     
  6. jpmohr

    jpmohr Member

    Joined:
    Jan 25, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    I have version: WHM 11.23.0 cPanel 11.23.3-R25133

    And it's listed for me under "Filters" as "SpamAssassinTM: Text to be added Subject line for messages marked as spam. [?]". I'm not sure about other cPanel updates (HOPEFULLY when I update to 11.24, I won't lose the option!).
    I have it set as: ***SPAM? ($spam_score)***

    - Jim.
     
  7. FrankyKnife

    FrankyKnife Member

    Joined:
    Mar 27, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zurich (CH)
    you mean WHM >> Exim >> Filters ?
    i only have the option "System Filter File" there. nothing with spamassassin!

    or do you mean Cpanel >> Spamassassin / E-mail Filtering ?
    i have no "SpamAssassinTM: Text to be added Subject line for messages marked as spam" option there anywhere.


    strange! what's going on??? :-(
     
  8. jpmohr

    jpmohr Member

    Joined:
    Jan 25, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    It's in WHM.

    I am not sure if the order of your WHM menu sections on the left is the same as mine, but it is my 7th section from the top: "Services Configuration".

    The option for Exim Configuration Editor should be listed there.

    Under the "Standard Options" bullet, mine lists "Filters" Under it is "SpamAssassinTM: Text to be added Subject line for messages marked as spam.", where I added the text: ***SPAM? ($spam_score)***

    If you can't find it, do you have Spam Assassin installed? Is that something you have to install separately first?? (I didn't think of that until after I wrote the above). My VPS had it installed already, so I didn't have to do anything extra.... But, I'm wondering if that might be the reason you don't see the option....

    I hope that helps.
    Jim
     
    #8 jpmohr, Feb 6, 2009
    Last edited: Feb 6, 2009
  9. FrankyKnife

    FrankyKnife Member

    Joined:
    Mar 27, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zurich (CH)
    WHM:
    i have spamassassin 3.2.4 installed. tried to do a rpm force re-install, but it prompted back: already installed - no update/changes done!


    Cpanel:
    "Please note that SpamAssassin is not configured for rewrites. You should check the X-Spam-Bar header for the spam bar in your filter, or for simplicity, you can also check the X-Spam-Status header for Yes or No."
    Code:
    X-Spam-Flag: YES
    X-Spam-Checker-Version: SpamAssassin 3.2.4 (2008-01-01) on
    	domain.com
    X-Spam-Level: *******
    X-Spam-Status: Yes, score=7.2 required=4.0 tests=BAYES_20,DCC_CHECK,
    	FH_FROMEML_NOTLD,MISSING_DATE,MISSING_HEADERS,MISSING_MID,MISSING_SUBJECT,
    	NO_HEADERS_MESSAGE,NO_RECEIVED,NO_RELAYS shortcircuit=no autolearn=no
    	version=3.2.4
    X-Spam-Report: 
    	*  0.0 MISSING_MID Missing Message-Id: header
    	*  2.7 FH_FROMEML_NOTLD E-mail address doesn't have TLD (.com, etc.)
    	*  0.0 MISSING_DATE Missing Date: header
    	* -0.0 NO_RELAYS Informational: message was not relayed via SMTP
    	*  1.3 MISSING_HEADERS Missing To: header
    	* -0.7 BAYES_20 BODY: Bayesian spam probability is 5 to 20%
    	*      [score: 0.0759]
    	*  2.2 DCC_CHECK Listed in DCC (http://rhyolite.com/anti-spam/dcc/)
    	*  1.8 MISSING_SUBJECT Missing Subject: header
    	* -0.0 NO_RECEIVED Informational: message has no Received headers
    	*  0.0 NO_HEADERS_MESSAGE Message appears to be missing most RFC-822
    	*      headers
    From: "Spam Assassin" 
    
    Spam Assassin has been enabled on this account
    

    WHM >> exim config >> filters = NO spamassassin (see picture)


    @cpanel team:
    is this the standard? looks like there is something wrong?!
    where and how is the config for?
     

    Attached Files:

Loading...

Share This Page