The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Howto? SSL e-mail with Exim?

Discussion in 'E-mail Discussions' started by Arcie, Apr 17, 2007.

  1. Arcie

    Arcie Member

    Joined:
    Jan 1, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    So I saw a demo of an easily-downloaded software package that lets someone log ANY unsecured traffic on open WiFi access points. If you don't know, unless you're "https" your login IDs and passwords go over the network unencrypted. That means your e-mail logins and passwords.

    Lots of e-mail packages (e.g., Eudora) have built-in SSL mail exchanges. But it doesn't work on default cPanel installations. So how, please, can I set up Exim on my cPanel box to allow SSL e-mail transactions? I'm going to be doing a lot of travel this year, and I'd like to be more confident when connecting to public WiFi access points, like in hotels and coffee shops....
     
  2. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    323
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    Actually I setup my email clients to connect using ssl and it worked - no change to the server. I use Agent and Pop Peeper, both using ssl.

    Ron
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    SSL is enabled by default.
     
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    we've tried it with Outlook Express, doesn't seem to work either. anyone gotten it to work with Outlook ... ?

    Mickalo
     
  5. Arcie

    Arcie Member

    Joined:
    Jan 1, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    Thanks, Ron. Doesn't work for me -- I get an error:

    Code:
    Logging into POP Server, CAPA
    Server does not support SSL
    So are you using a different port or anything?
     
  6. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    323
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    SSL for pop email uses port 995 on my server. This is the default as far as I know.

    Ron
     
  7. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    oh really? I also got a no ssl support error message in Outlook while trying to use SSL SMTP thru my cPanel supplied exim.

    any suggestions?
    how can we check it? make sure it's running right and what ports it's using?
     
  8. Arcie

    Arcie Member

    Joined:
    Jan 1, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    I'm still having trouble too. If the cPanel people are so sure this should be easy, then show us how easy it is!
     
  9. nisse

    nisse Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    The POP port is 995.
    The SMTP port is 465.
     
  10. 757Mike

    757Mike Registered

    Joined:
    Mar 13, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Enable SSL

    My Email provider uses cpanel and we required SSL, it took us a while to figure it out but we got it up and running. I found this somewhere, you may want to try it:

    Edit the file /usr/sbin/antirelayd
    On line 101
    This line
    if ($server !~ /(cpanelpop|cppop|pop3d|imap|imapd)$/) {

    Change it to look like the line below, an Exim Restart may be needed

    if ($server !~ /(cpanelpop|cppop|pop3d|imap|imapd|imapd-ssl|pop3d-ssl)$/) {

    I'm not sure if it will be line 101 on your server, but if you search for that first line and its missing the -ssl portions you need to add them in.
     
  11. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Mine looks similar to yours, but I still can't get SSL to work. Sending an email, I get this:


    I have port 995 for POP3 & port 465 for SMTP

    How do I enable SSL for email?
     
Loading...

Share This Page