The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

.htaccess doesn't do anything

Discussion in 'General Discussion' started by Blapto, Aug 25, 2005.

  1. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    My own .htaccess files and those generated by cPanel do absolutely nothing, they are ignored.
    Nothing mentioning it in the log in /usr/local/apache/domlogs
    /scripts/upcp --force doesn't help

    <Directory />
    Options All
    AllowOverride All
    </Directory>

    Appears in my httpd.conf, and nothing else pertaining to /home directories does at all.

    Any ideas?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I'd keep scouring httpd.conf. Overrides and options are often changed multiple times and it can get a bit confusing as to whether they're still enabled by the time you get down to the VirtualHosts.
     
  3. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    less httpd.conf | grep -A 2 -B 2 AllowOverride
    <Directory />
    Options All
    AllowOverride All
    </Directory>

    --
    # "AuthConfig", and "Limit"
    #
    AllowOverride None

    #
    --
    #
    #<Directory /home/*/public_html>
    # AllowOverride FileInfo AuthConfig Limit
    # Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    # <Limit GET POST OPTIONS PROPFIND>
    --
    <Directory "/usr/local/apache/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    --
    <Directory "/usr/local/apache/htdocs/manual">
    Options Indexes FollowSymlinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    --
    #
    <Directory "/usr/local/apache/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    So, it looks like the last general one turns them all off, depending on the context:

    AllowOverride None
     
  5. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    That second entry is in a Directory section starting
    <Directory "/usr/local/apache/htdocs">
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's odd then. Any errors in the error_log when browsing to a .htaccess directory?
     
  7. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    /var/log/httpd/access_log is empty
    /usr/local/apache/logs/access_log isn't showing anything abnormal
    /usr/local/apache/domlogs/ isn't showing anything abnormal

    Anywhere else to look?
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    What about /usr/local/apache/logs/error_log
     
  9. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Nothing of note there either.
     
  10. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    I've even added
    <Directory /home/(a user)/*>
    Options All
    AllowOverride All
    </Directory>

    and still no joy.
     
  11. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I ran "less httpd.conf | grep -A 2 -B 2 AllowOverride" and the result is identical to yours, so I really don't think there is a problem with your httpd.conf. Very strange...
     
  12. Blapto

    Blapto Active Member

    Joined:
    May 13, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Right, I've got it working now, had to faff around inside the .htaccess file itself.
    Now to find out why cPanel isn't making correct .htaccess files.
     
Loading...

Share This Page