The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

.htaccess settings and ExecCGI problems

Discussion in 'General Discussion' started by qwerty, Aug 3, 2004.

  1. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    One of our clients installed a script which comes with a .htaccess file with a whole bunch of settings. The following 3 lines prevent the script from running or the directory from being viewable at all

    Options -Indexes
    Options FollowSymLinks
    Options FollowSymLinks -Indexes

    It logs the following in the error log:

    [Tue Aug 3 18:15:43 2004] [error] [client xxx.xxx.xxx.xxx] Options ExecCGI is off in this directory: /home/username/public_html/scriptdir/index.php

    We are using phpSuExec and suexec as well.

    Is there any way to get those 3 settings above to work on this server? Anything I try fails .. help would be appreciated
     
  2. Faldran

    Faldran Well-Known Member

    Joined:
    May 28, 2002
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    Yes, replace those three lines with this one:

    Options FollowSymLinks -Indexes +ExecCGI



    When you set any of the options, it over-rides the ones in httpd.conf and thus you will have to manually add the ExecCGI to it, to make php work without getting 500 errors.
     
  3. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16

    Thanks a lot, worked.
     
Loading...

Share This Page