The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HTML editor - FileManager

Discussion in 'General Discussion' started by rodesignweb, May 23, 2008.

  1. rodesignweb

    rodesignweb Member

    Joined:
    Aug 5, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have an index.html file and the problem is that contains a javascript :

    <script>
    ...
    </script>

    The problem is that HTML editor will display this:

    '); newWindow.document.write('
    '); newWindow.document.write('Click screen to close'); newWindow.document.write('

    If I remove the JavaScript code everything is working fine. I also attached to this the script that I am using. My questions are: is html editor not supporting JavaScript code, or my code has something that is not working good?

    Please advice. Thanks!
     

    Attached Files:

  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What is your full cPanel version number?

    There was some oddities with the HTML Editor and Javascript that we fixed in the 11.23 builds, but the 11.18 builds don't have the fixes.
     
  3. rodesignweb

    rodesignweb Member

    Joined:
    Aug 5, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I am using cPanel 11.18.6-R24255
    Can you please provide some details regarding this?
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    With IE, we found that some javascript was being parsed and executed, thereby modifying the underlying document, simply by switching between the preview and code modes. FireFox didn't have this problem (nor other browsers tested, only IE)
     
Loading...

Share This Page