Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

.htpasswds: Incorrect permissions

Discussion in 'General Discussion' started by richy, Mar 2, 2006.

  1. richy

    richy Well-Known Member

    Joined:
    Jun 30, 2003
    Messages:
    276
    Likes Received:
    1
    Trophy Points:
    168
    We've had one user (so far) complain about the WysiwygPro editor not allowing him to login to edit the pages (FileManager->Click File->Click WysiwygPro editor->New window opens with login details->Copy login details).

    I then created a "Password Protected Directory/Web Protect" via cPanel, but was unable to login with the details I entered. I deleted the /home/USERNAME/.htpasswds folder and tried again (which forced cPanel to recreate that folder anew), but again without success.

    Looking into the issue showed the permissions of the folder thusly:
    drwxr-x--- 2 USERNAME USERNAME 4096 Mar 1 19:06 .htpasswds/
    when they should have been (according to other servers):
    drwxr-xr-x 2 USERNAME USERNAME 4096 Mar 1 19:06 .htpasswds/
    (i.e. "other" cannot read/execute that folder)

    Any idea why this (100% repeatable on that account) problem occurs and how to permanently fix it. We were running on RedHat Enterprise 3 i686 WHM 10.8.0 cPanel 10.8.1-E40 , but tried upgrading to WHM 10.8.0 cPanel 10.8.2-E3 but there was no difference. We're running phpSuExec/suExec as well.
     
  2. monoxide

    monoxide Member

    Joined:
    Jun 14, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    151
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. richy

    richy Well-Known Member

    Joined:
    Jun 30, 2003
    Messages:
    276
    Likes Received:
    1
    Trophy Points:
    168
    I know all that - it's not the issue.

    Basically, whenever CPANEL automatically created the /home/USERNAME/.htpasswds folder, it sets it with permissions of 750 instead of 755 which prevents logins.

    This folder is automatically created when:
    - The "HTML Editor" in the "File Manager" is started
    - A user selects the "Password Protect Directories/Folders" option on their cPanel control panel

    We've had this occur with a second server (and user) so it's definetly a bug in WHM 10.8.0 cPanel 10.8.2-E3 and some earlier versions.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Then you need to log it with cPanel.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. richy

    richy Well-Known Member

    Joined:
    Jun 30, 2003
    Messages:
    276
    Likes Received:
    1
    Trophy Points:
    168
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice