HTTP 500 error after easyapache update


Jan 1, 2020
cPanel Access Level
Website Owner
Recently, I updated easyapache 3 to 4 for update php version on my website.
After that, http 500 error showed up and then tried revert 3 from 4, however, ea3 is no longer available.

I tried to figure out what problem was in there so that looked up error log in cPanel.

Some of errors on there, these are just parts of errors on there that I just posted.

PHP Warning: PHP Startup: Unable to load dynamic library './' - ./ cannot open shared object file: No such file or directory in Unknown on line 0
[30-Dec-2019 11:32:31 America/Chicago] PHP Warning: PHP Startup: Unable to load dynamic library './' - ./ cannot open shared object file: No such file or directory in Unknown on line 0

and then also

PHP Warning: Creating default object from empty value in /home/ugaksa/public_html/modules/module/module.model.php on line 100
style='color:black'>[30-Dec-2019 11:32:51 America/Chicago] PHP Strict Standards: Non-static method DB::getInstance() should not be called statically in /home/ugaksa/public_html/config/ on line 210

and then
[31-Dec-2019 17:55:41 UTC] PHP Fatal error: Uncaught Error: Using $this when not in object context in /home/ugaksa/public_html/classes/context/Context.class.php:595

How should I proceed to solve these problem?
Last edited by a moderator:


Technical Analyst
Staff member
Sep 6, 2018
cPanel Access Level
Root Administrator

PHP Warning: PHP Startup: Unable to load dynamic library './'

This indicates that you've got some .ini file somewhere with settings that shouldn't be there. It would be hard to say exactly what without access to your server. You may wish to consider submitting a ticket.

With the other two errors, it's hard to say for sure without further context and access. However, my first suggestion would be to make sure that you have all of the PHP versions, modules, and extensions that you need installed on the server using the WHM » Easy Apache 4 interface.

We have documentation on this here:

If you need to try a different PHP version out (if your code is old, you may wish to try PHP 5.4), you can change the PHP version for the site using the MultiPHP Manager interface:

If you require any PHP version older than 5.4, you'd need to use CloudLinux (they provide "hardened" EOL PHP packages compatible with EA4).

If you still have any trouble after this, I'd recommend submitting a support ticket.


Apr 2, 2020
San Miguel CA
cPanel Access Level
Root Administrator
I'm not sure if I should add my related problem to this thread or start a new one. I searched keywords and this is the closest thread.
I am trying to update to apache4 as well and keep getting redirected to fixing apache 3 first and ran into this error:

checkyum version 22.3

!! Package system can not be repaired automatically !!

!! Please visit for help with this error. !!

!! Restoring original working apache !!
I went to the URL and tried updating software and got this error:

“yum” reported error code “1” when it ended: w/ yum -y
Often errors like this can be resolved by running `yum makecache`

so I started Terminal (and prayed I would not screw up whole system) and tried 'yum makecache" and here is the error I got for 'yum makecache' :

Error: Cannot retrieve repository metadata (repomd.xlm) for repository: epel. Please verify its path and try again
I need assistance here. Need to know its usual path -- perhaps moved when I added gis app? I love registry where you can search, yet don't suppose there is anything comparable here. Thanks for any assistance.