The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

http Crash at night

Discussion in 'General Discussion' started by kris1351, Jan 18, 2004.

  1. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Get this every night, there a way to get around it? It causes httpd to die every single night.

    Fetching package list for channel: rhel-i386-es-3...

    Fetching Obsoletes list for channel: rhel-i386-es-3...

    Fetching rpm headers...

    Name Version Rel
    ----------------------------------------------------------
    httpd 2.0.46 26.ent i386
    ypbind 1.12 5 i386


    Testing package set / solving RPM inter-dependencies...
    httpd-2.0.46-26.ent.i386.rp Retrieved.
    ypbind-1.12-5.i386.rpm: Retrieved.
    Preparing
    Installing /var/spool/up2date/httpd-2.0.46-26.ent.i386.rpm...
    service httpd does not support chkconfig There was a fatal RPM install error. The message was:
    There was a rpm unpack error installing the package: httpd-2.0.46-26.ent Testing connection speed...(this could take a while)....Done Five usable mirrors located
     
  2. tizoo

    tizoo Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Experiencing the same problem

    Hi !

    I'm also experiencing the same problem here on redhat...

    I saw in the logs that apache is just restarted... but it is nevertheless an uptime killer...

    Since cPanel uses it's own apache build, shouldn't we get rid of this problem by uninstalling the RH-rpm version of apache (I'm assuming that the unpack error comes from this version, instead of the cPanel one)

    I'd appreciate some confirmations before I start to do something silly...
     
  3. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Same Situation Here!

    I am also having the same issue. I have submitted a ticket to cPanel to see if they have a solution for it. Any suggestions are welcome!

    cPanel.net Support Ticket Number: 35767
     
  4. pguy

    pguy Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    We too are having the same problem. Checked var/log/messages and found the below error at the same time apache goes down -

    Jan 18 02:47:07 sb modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.21-4.0.2.EL/modules.dep (No such file or directory)

    By the looks of it..is it caused by RHEL ? Which OS are you guys running ?
     
  5. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    RHE 3.0
     
  6. pguy

    pguy Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Same here !
     
  7. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Here is cPanel's tech first response to my inquiry.

    ------------------

    Hello, is there any downtime due to the failure or is it just an email notice? Most likely cPanel is just restarting apache and that causes chkservd to send out the email, anytime cPanel updates it has to restart apache but should not cause it to fail.

    -------------------------------------------------
     
  8. pguy

    pguy Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    We actually had downtime. Plus they asked us to rebuild apache. Didn't really make sense though. The machine was up for a week, but the issue has come up in the last 2 days.

    Plus as per the logs chkservd did not start apache in 5 mins. It took it an odd 8 minutes after shutdown to restart... Will try a rebuild of apache if it fails tonight too.. and then proceed with a kernel update...
     
  9. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    pguy,

    Been there done that, great minds think alike. I have upgraded the kernel, two days ago, and tonight rebuilt apache with no success.

    Let me know if you get it solved. I will do the same.
     
    #9 DataDork, Jan 18, 2004
    Last edited: Jan 18, 2004
  10. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    What version of cPanel?

    OK, so it looks like a RHE vs. cPanel issue. What version of cPanel are you running? I was using "Stable" but went to "Edge" on one production box in an un-sucessful effort to correct it.
     
  11. pguy

    pguy Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Latest Edge. No problems there though. All our servers are running latest Edge without any issues. It definitely seems like a Cpanel V/S RHE issue. Just check your /var/log/message tonight if the server goes down. error_log doesn't hold much clue. It shows a normal httpd shutdown
     
  12. GXX

    GXX Registered

    Joined:
    Dec 18, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    have the same issue here, httpd crashes each nite at the same time. but it gets restarted automagically.

    here's the the update script sends me which i think is causing the issue:

    There was a fatal RPM install error. The message was:
    There was a rpm unpack error installing the package: httpd-2.0.46-26.ent
     
  13. Joshfrom

    Joshfrom Well-Known Member

    Joined:
    Jun 3, 2003
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    White Haven, PA, US
    Please submit a ticket on this problem, and post the ticket number you submitted in this thread.
     
  14. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    cPanel.net Support Ticket Number: 35767
     
  15. GXX

    GXX Registered

    Joined:
    Dec 18, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Support Log for Request 35819
     
  16. pguy

    pguy Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Cpanel ticket - 35707
     
  17. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    I know the problem, Michael pointed it out in an email. Cpanel is using up2date now for updates and it is trying to update httpd and ypbind. Add this to option 24 in up2date --configure and it fixes the problem. Make sure you leave the two kernel options in the skip list also.
     
  18. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Thanks Kris! That seems to have solved this issue.
     
    #18 DataDork, Jan 19, 2004
    Last edited: Jan 19, 2004
  19. brumie

    brumie Active Member

    Joined:
    Dec 9, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Thanks Kris!

    Code:
    up2date --configure
    24
    Attribute: pkgsToInstallNotUpdate
    Comment: A list of provides names or package names of packages to install not update
    Current value: kernel;kernel-modules;
    < return for default, C to clear list, items are ';' separated >
    New Value: httpd;ypbind;kernel;kernel-modules 
    
    then i press enter to save and exit
    and i ran upcp to test it,
    and up2date still installing both application httpd, ypbind but httpd is not down like before

    am i correct or do i missed something here?

    Thanks in advance
    Brumie
     
  20. tizoo

    tizoo Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Worked for me... kind of

    Hi !

    I just tested this workaround... however, it did not work me out of the box.

    I had to put "httpd" in the pkgSkipList configuration directive. (option 8).

    It now works...

    Hope this helps someone !

    Best regards,
     
Loading...

Share This Page