The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

http not working after certificate installation

Discussion in 'General Discussion' started by shantanuthatte, Oct 25, 2012.

  1. shantanuthatte

    shantanuthatte Registered

    Joined:
    Oct 25, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I purchased Standard SSL certificate from GoDaddy, moved the site to a dedicated IP, generated CSR, got the Cert, installed it.

    As I did so many times earlier, but this time going to http://domain.com resulted in "Connection Refused" where as https://domain.com resulted in proper site with the cert properly displayed.

    I uninstalled the certificate, but still the prob persisted. I moved the site back to shared IP, and it worked normally, and as expected https gave an SSL error.

    So I tried the process again, moved to dedicated IP, but without installing the cert I did https://domain.com, it worked, cPanel showed (none) as installed SSL host. So installed again, still no success.

    Currently I have reverted it back to the shared IP

    Note: this is a new VPS that I have just setup, with CSF, Mod Security, etc installed.

    What am I doing wrong ?
     
  2. MilesWeb

    MilesWeb Well-Known Member
    PartnerNOC

    Joined:
    May 23, 2012
    Messages:
    174
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Monitor apache error logs when certificate is being installed. This should help you to investigate it further.
     
Loading...

Share This Page