Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

http not working after certificate installation

Discussion in 'General Discussion' started by shantanuthatte, Oct 25, 2012.

  1. shantanuthatte

    shantanuthatte Registered

    Oct 25, 2012
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    I purchased Standard SSL certificate from GoDaddy, moved the site to a dedicated IP, generated CSR, got the Cert, installed it.

    As I did so many times earlier, but this time going to resulted in "Connection Refused" where as resulted in proper site with the cert properly displayed.

    I uninstalled the certificate, but still the prob persisted. I moved the site back to shared IP, and it worked normally, and as expected https gave an SSL error.

    So I tried the process again, moved to dedicated IP, but without installing the cert I did, it worked, cPanel showed (none) as installed SSL host. So installed again, still no success.

    Currently I have reverted it back to the shared IP

    Note: this is a new VPS that I have just setup, with CSF, Mod Security, etc installed.

    What am I doing wrong ?
  2. MilesWeb

    MilesWeb Well-Known Member PartnerNOC

    May 23, 2012
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Monitor apache error logs when certificate is being installed. This should help you to investigate it further.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice