The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Http process won't die off and eating up cpu & ram.

Discussion in 'General Discussion' started by gundamz, Mar 2, 2008.

  1. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    I have this apache process that did not die off. it appear to be some robot running around trying to exploit web script based on what i see .

    Look at process number 19056 ..
    I wonder what is wrong.

    My apache settling :
    timeout 30

    Using a custom mod_security 2.


    I am using apache 2.2
    WHM 11.15.0 cPanel 11.18.1-R20683
    CENTOS Enterprise 5 i686 on standard - WHM X v3.1.0

    Top:

    http://i31.tinypic.com/ffdan4.jpg


    Apache status via WHM:

    http://i26.tinypic.com/2na2s12.jpg
     
    #1 gundamz, Mar 2, 2008
    Last edited by a moderator: Mar 2, 2008
  2. Bailey

    Bailey Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Wisconsin
    Secure the script, and those commands won't be able to be run.

    This is why to keep scripts patched.

    :D Bailey
     
  3. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    No, it doesn't related to script.

    The bot is executing on a non-web script directory..
    I wonder what is wrong with apache.. :confused:
     
  4. XzaB

    XzaB Active Member

    Joined:
    Nov 20, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Egypt, Cairo
    Hey YOU !!! Adding many rules into mod_security make HTTP Process eating your CPU as u said !

    so you have 2 choices get rid into new better performed server or try to optimize your mod_security rules for what u exactly only needed from the installed rules !

    as i was facing same as your problem before but i did optimized for better and now httpd is only getting 4% of CPU
     
Loading...

Share This Page