PatrickVeenstra

Well-Known Member
Feb 12, 2012
171
6
68
Barcelona
cPanel Access Level
Root Administrator
The following conflicts are installed on this machine. They will be removed as part of this package selection:
mod_cgi
php56-php
mod_mpm_prefork

Should I care? I'm using PHP 5.6 with DSO. Sounds like it's forcing me to upgrade to PHP 7, is that true?
Will performance be worse because of not using prefork but event based? If I remember well it is a bit slower, but I'm not sure about the current state.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @PatrickVeenstra,

It's actually the DSO and CGI handlers along with the prefork MPM that conflict with Mod_HTTP2. Prefork and HTTP2 are not compatible due to the technology behind how they are developed, and the DSO handler (php56-php) requires the MPM Prefork Apache module.

PHP-FPM with the Event MPM is an alternative that will allow you to use HTTP2 and avoid using insecure permissions for PHP files. There's some discussion of the various options you can use at:

Prefork and HTTP2

Additionally, for information about file permission requirements for PHP handlers and MPM options, please see:

PHP Handlers - EasyApache 4 - cPanel Documentation
Multi-Processing Modules - MPMs - EasyApache 4 - cPanel Documentation

Thank you.