httpd 100% CPU until restart when trying to a access https on proxy domain

nick122147

Member
Sep 9, 2013
13
0
1
cPanel Access Level
Root Administrator
I know it doesn't work to access proxy subdomain through https through regular ports.

However if someone still types in https://webmail.domainename.com this below error displayed, and httpd process goes to 100% and stays at 100% CPU until httpd is manually restarted.

I was told by buycpanel support that this is normal and there is nothing to do about this.
However, isn't this a serious issue/bug?
Or is buycpanel support wrong and there an issue with my setup?

Proxy Error

The proxy server could not handle the request GET /.
Reason: Error during SSL Handshake with remote server

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

It's not normal for your server to reach 100% CPU usage and remain that way until Apache is restarted. It sounds like this is occurring as a result of the content served. Do you have a SSL certificate installed on that IP address for another account? Feel free to open a support ticket so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

nick122147

Member
Sep 9, 2013
13
0
1
cPanel Access Level
Root Administrator
Hi, thanks for the reply!
I have a multi domain certificate installed that covers hostname, domains and subdomains, one IP address for everything. However the certificate doesn't include the "webmail" address. If I go to https://webmail.domaine.com:2096 then it works (with the browser warning about the certificate name mismatch).

I bought the cPanel license from buycpanel. Can i still open a ticket here?