Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Httpd.conf problems

Discussion in 'General Discussion' started by Stig, Jun 5, 2005.

  1. Stig

    Stig Member

    Joined:
    Mar 26, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    151
    Hi
    After i did a apache recompile my webserver has been acting really strange frist of all it messed up part of the php scripts on my server ...
    When i did remove the modules i had installed it was even more messed up.
    i just wonder if there are a way to do a fresh install of apache and add the accounts without having to delet the content in the /home dir.
    i also noticed it is usine VirtualHost instaed of NamedVirtualHost witch one should be used =??

    are there any script(s) in the /scripts folder witch can help me solve this problem ??
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    There are many threads discussing Apache and related problems. If none works, I suggest hiring a sys admin to solve this problem. We can help :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Hello,

    please check the following entries in your httpd config file.
    ==========================================
    LoadModule php4_module libexec/libphp4.so
    ----------------------------------------------------------
    AddModule mod_php4.c
    ==========================================

    If it is commented, commend out first and restart httpd.

    This command will help you to recompile apache
    ====================================
    /scripts/easyapache
    ====================================

    And select the option 6
    But you should take back up of your apache folder [/usr/local/apache/ or libexec and httpd.conf ] before doing it..

    Yeah , You can use both. If you use "Namevirtualhost" add this entry above the virtualhost section.

    NameVirtualHost Ip:80

    <VirtualHost Ip>
    ServerAlias www.domainname domainname
    ServerAdmin webmaster@domainname.com
    --------------------------------------
    -------------------------------------
    </VirtualHost>

    May be it will help you to solve your issue ;)

    Let me know the status.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice