The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd dead... version LIBXML2_2.6.28 required by....

Discussion in 'General Discussion' started by HorburySchool, Jun 22, 2011.

  1. HorburySchool

    HorburySchool Active Member

    Joined:
    Dec 14, 2007
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Wotcha peeps - just wondering if anyone had a quick fix for the following:

    Code:
    bigsis# ./apachectl -k start
    httpd: Syntax error on line 41 of /usr/local/apache/conf/httpd.conf: Syntax error on line 17 of /usr/local/apache/conf/php.conf: Cannot load /usr/local/apache/modules/libphp5.so into server: /opt/xml2/lib/libxml2.so.9: version LIBXML2_2.6.28 required by /usr/local/apache/modules/libphp5.so not defined
    
    This is as a result of recompiling EasyApache to add XMLRPC support to PHP5.3.5

    Configure command as follows:
    Code:
    ./configure --disable-fileinfo --disable-pdo --disable-phar --enable-bcmath --enable-calendar --enable-exif --enable-ftp --enable-gd-native-ttf --enable-intl --enable-libxml --enable-magic-quotes --enable-mbstring --enable-soap --enable-sockets --enable-zip --prefix=/usr/local --with-apxs2=/usr/local/apache/bin/apxs --with-bz2 --with-curl=/opt/curlssl/ --with-freetype-dir=/usr/local --with-gd --with-gettext --with-icu-dir=/usr/local --with-imap=/opt/php_with_imap_client/ --with-imap-ssl=/usr/local --with-jpeg-dir=/usr/local --with-kerberos --with-ldap --with-libexpat-dir=/usr/local --with-libxml-dir=/opt/xml2 --with-libxml-dir=/opt/xml2/ --with-mcrypt=/opt/libmcrypt/ --with-mssql=/usr/local --with-mysql=/usr/local --with-mysql-sock=/tmp/mysql.sock --with-mysqli=/usr/local/bin/mysql_config --with-openssl=/usr/local --with-openssl-dir=/usr/local --with-pcre-regex=/opt/pcre --with-png-dir=/usr/local --with-unixODBC --with-xmlrpc --with-xpm-dir=/usr/local --with-xsl=/opt/xslt/ --with-zlib --with-zlib-dir=/usr --without-sqlite3 
    
    Have opened a support ticket but management here are pushing me for a speedy solution...

    Platform is FreeBSD 8.2
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What perl version do you happen to have on this machine?

    Code:
    perl -v
    In a prior ticket where I checked for this same error on FreeBSD, it was due to using Perl 5.12 rather than Perl 5.10

    Also, I have been unable to find any technical support ticket in our system showing these same errors today, so did you open the ticket with cPanel technical support?
     
Loading...

Share This Page