Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

httpd-devel installation blocked

Discussion in 'EasyApache' started by Volt55, Feb 20, 2017.

  1. Volt55

    Volt55 Member

    Joined:
    Feb 20, 2017
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I tried to install mod_geoip using the method on this website:

    - Removed -

    At the point where I need to install httpd-devel it fails, saying "Error: Nothing to do". I tracked this down to yum.conf blocking the installation. My question is, if I allow this install to go ahead (by removing the block), is there a chance that it could mess up my server? I have client websites on there so it's particularly important for me.

    The only reason I need http-devel is to run apxs, the Apache Extension Tool. Any other methods to get mod_geoip on there would be welcomed.

    Thanks in advance.

    Note: I'm running CentOS 7.3 and Apache2 on a Cloud Server with WHM/cPanel.
     
    #1 Volt55, Feb 20, 2017
    Last edited by a moderator: Jan 9, 2018
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,264
    Likes Received:
    1,940
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    The instructions in that guide are unsupported due to how Apache is implemented with cPanel. Try using the instructions on the following post instead:

    EasyApache 4 Questions

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    97
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    You'll want to install 'ea-apache24-devel' package, as this will contain apxs
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice