The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd down magically :)

Discussion in 'General Discussion' started by bsasninja, Oct 21, 2008.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    today at 5 am I received this message:

    httpd failed @ Tue Oct 21 06:31:26 2008. A restart was attempted automagically.

    Failure Reason: Timeout while trying to get data from service


    and then more than 20 messages with this different message:

    httpd failed @ Tue Oct 21 06:41:03 2008. A restart was attempted automagically.


    Failure Reason: Unable to connect to port 80


    I did a service httpd stop/start/restart but nothing happened. The system said that httpd has been restarted, started, stoped but no httpd process was listed.

    So I have to execute apache manually /usr/local/apache/httpd and then it worked.
    Do you know why It doesnt respond through the start, restart or stop command??

    Thanks
     
  2. ggooden

    ggooden Member

    Joined:
    Dec 9, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pasadena, California, United States
    cPanel Access Level:
    Root Administrator
    I am seeing the precise same problem in the last two days. I was sad to see no replies to your question.
     
  3. hzJayJ

    hzJayJ Well-Known Member

    Joined:
    Nov 14, 2008
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    Did you checked the error logs, most of the errors will be logged inside the error_log file.

    You can find the error log at :

    /usr/local/apache/logs/error_log
     
  4. Haaser

    Haaser Active Member

    Joined:
    Nov 17, 2008
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    unable to connect to port 80 almost seems like the httpd or apache service did not get killed. Maybe the process is still running. Check your "Apache Status" to see if it is still running.
     
  5. goldclub

    goldclub Member

    Joined:
    Nov 20, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    how to run execute apache manually /usr/local/apache/httpd from red hat grub how to get to command line? I'm not able to connect via putty or cpanel's WHM
     
  6. stdout

    stdout Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    189
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Nelspruit, Mpumalanga, South Africa
    cPanel Access Level:
    Root Administrator
    You can do either "service httpd start", "/etc/init.d/httpd start", "httpd start" or an "apachectl start".
     
  7. cookiesunshinex

    cookiesunshinex Well-Known Member

    Joined:
    Jun 10, 2005
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    I'm getting this problem. HTTP won't start.

    Here's the error:
    Syntax error on line 9 of /usr/local/apache/conf/php.conf:
    Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/lib/libmysqlclient.so.14: version `libmysqlclient_14' not found (required by /usr/local/apache/libexec/libphp5.so)
    /usr/sbin/httpd start: httpd could not be started


    I just recently upgraded to both PHP5 and then MySQL 5.0.

    I got httpd up by editing /usr/local/apache/conf/php.conf: and commenting out the line that says: LoadModule php5_module libexec/libphp5.so

    Should I recompile apache?
     
  8. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    it appears to be an issue with compiling php5. You will need to recompiling, with mysql module and check easyapche logs for any errors too.
     
  9. cookiesunshinex

    cookiesunshinex Well-Known Member

    Joined:
    Jun 10, 2005
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    Simply recompiling Apache with all the same settings fixed the issue.

    This all started because I had a problem with upcp:
    This error:
    MySQL 5.0.24 is up to date
    /usr/local/apache/libexec/libphp4.so: /usr/lib64/libmysqlclient.so.14: version `libmysqlclient_14' not found (required by /usr/local/apache/libexec/libphp4.so)

    which is exactly the problem mentioned here:
    http://forums.cpanel.net/showthread.php?t=58308
     
    #9 cookiesunshinex, Jan 12, 2009
    Last edited: Jan 12, 2009
Loading...

Share This Page