The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd-DSSL processes not closing, creating HUGE server loads

Discussion in 'General Discussion' started by kennyp, Apr 2, 2004.

  1. kennyp

    kennyp Registered

    Joined:
    May 29, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    Im having a very wierd problem it seems every ten minutes or so, sometimes a bit longer i get these processes, either root or nobody as user that do not close and eventualy suck the life out of the cpus.

    Ive tried every fix posted in these forums and so far no luck at fixing it. I have 5, dual zeon machines, each running a gig of memory. 4 of my machines have this problem in different degrees.

    I cant match the processes to a site in Apache usage on WHM because they are no longer listed in apache processes although i do see then in the process list and when i call up top via ssh . I can sit and watch top and see thet process start and almost set my clock to thet server load rising. If I kill the process, usually a nobody one with a different pid one comes along and the only temp solution i have found is rebooting apache and then things are fine till the next http-DSSL process comes along and it doesnt seem to afftect anything till its been running for a few minutes which i dont think is normal.

    Ive been running my servers on my own for 3 years and although self taught seem to have a good handle on thngs for the most part. This is the first time I have seen anything like this .

    If i helps the machine that is the worst its the only I have that a master/slave (its thet slave) configturtaion or I should say the new clustering configuration which I suspect may be part of the problem. Dont know why they changed it, master/slave always worked fine for me in the past .

    One last thing, if I kill the root process then kill the nobody one that always seems to show up, apache seems to crash as I cant access any webpages, although if i just reboot apache, processes disappear and server load drops to normal levels

    First thought corupted apache, i have reinstalled numerous times as well as reinstalling exim. On the machine with the most problems Im running redhat 9 with cpanel 9.1 stable 93.

    If anyone knows the source of my protblem and a fix I would be etertnally grateful.

    Thanks in advance

    Kenneth Poirier
    ByyteWorks Web Services
     
  2. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    I'm having a similar problem althought I'm not sure
    it's the same source causing it.

    Every now and then the cpu load goes up to high
    1,5-2,0 and the after a little, little while it goes down to
    normal - 0,2.

    2 days in a row my server has crashed and the NOC
    had to reboot it. I suspect it's the server load going
    above what it can take but I have never seen it live.

    I can't read the logs to see why this is happening.

    Before these 2 days everyhting was fine and I can't think
    of anything changed during this period.

    When I', looking live at the server I have onlu seen
    it go up to 0,5 or so and then its: httpd-DSSL processes
    running.
     
  3. kran

    kran Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Colombia
    cPanel Access Level:
    Root Administrator
    I´m having the same issues

    I´m having the same issues

    Any news??
     
  4. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Well, I upgraded to the release version of CP
    and ever since it has not crashed.
     
  5. fastactionhost

    Joined:
    Jul 14, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    We have the same problem.

    RHEL 3
    cPanel 9.2.0-E21

    This looks like a Cpanel bug...like Cpanel is not correctly communicating with Apache to terminate the sessions.

    Having to kill these manually is getting VERY old. :mad:
     
  6. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    We aslo :(

    WHM 9.1.0 cPanel 9.1.0-R85
    Fedora - WHM X v2.1.2

    Any idea to solve it?
     
  7. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
  8. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    I have not had any crash and the times I look I can't
    see any real high load anymore.

    What I did was to upgrade to the latest Release cPanel,
    stop the daily backups for one day and then back on.

    Worked for me, maybe a coinsident.
     
  9. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    To which version did you upgraded cPanel? And please tell me how did you that without any problems ;)
     
  10. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Now I have:

    WHM 9.2.0 cPanel 9.2.0-R20
    RedHat Enterprise 3 - WHM X v2.1.2

    this is the second time I updated since this issue
    Before when the issue was fixed I had another version
    9.1xxxx something.

    I just click on update to latest cpanel :)
    always worked fine with me.
     
  11. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    /scrpits/upcp worked for me well :)

    but...

    didn't solve high server loads problem. I think it shoul be memory problem - now I have only 512MB and almost 200 accounts, so it might be to low, because most of them have phpBB installed and use lot of mysql.

    and another funny thing - I've translated my cPanel into my country language, and I forgot to backup copy of this language file, so after updating cPanel you know... silly, silly...
     
  12. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    oh my god :), sorry about that.
    You know rvskin.com has alot of languages and is a really
    great skin/themes with much better "select what is included in the account" kind of stuff. Really great.
     
  13. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Still getting 1 or 2 httpd processes using all the CPU up as originally reported on RHEL with 9.2.0-R24.

    Dont know what to do about this, tried many things
     
  14. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Some say it's because of Tomcat and some say it's because of a SSL setting. Who knows...

    I don't think it's either of it...
    STrange no expert can answer this
     
  15. nettigritty

    nettigritty Well-Known Member
    PartnerNOC

    Joined:
    Jan 21, 2004
    Messages:
    194
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bangalore, India
    Use PRM from rfxnetworks to kill processes that are using too much cpu / resource
     
  16. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Bug in Cpanel 9.2 R24 on RHEL 3

    It seems that it is really bug in latest update of Cpanel on Rhel 3 causing me huge server loads on server with RHEL 3.

    I see hundreds of Apache httpd processes running and only when I restart httpd they are working ok.

    Does anyone know how to fix this? or how to downgrade cpanel to latest working version without this bug?
     
  17. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    two days ago and today these processes nearly killed
    my server again. I'm happy I did install the
    PRM from rfxnetworks. Now the server was only in critical state for about 3-5 minutes before the processes was killed.

    But sure something is really wrong here.
    BUt this is only on my celeron server not on my xeon server
    with same configuration.
     
  18. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    Could someone find the solutions? Maybe we shoul open the HUGE ticket :confused:
     
  19. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    I have solved it buy addition of httpd restart each 2 minutes in crontab.

    Before this I tried httpd restart each 5 minutes and still has problems with loads jump up to 100, only after httpd restarts each 2 minutes I see server is quite stable.

    It is only on my server with RHEL 3 , my another servers with RH 9 and Fedora are working ok with this version CPanel.

    Still this a bug and I already opened it in bugzilla of cpanel:
    http://bugzilla.cpanel.net/show_bug.cgi?id=464

    I am not sure this is a HUGE bug request, but still....
     
    #19 yaax, May 4, 2004
    Last edited: May 4, 2004
  20. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    You restart apache every 2 minutes ??

    That means your websites can't be reached
    during 10 seconds every 2 minutes or so.
     
Loading...

Share This Page