The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HTTPD error

Discussion in 'General Discussion' started by brforte, Nov 3, 2009.

  1. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I am a long time website developer and just recently decided to move all my customer sites from shared hosting to a virtual server with godaddy. I am a newbie in this area but feel like I have done an ok job with everything so far. I set up the server and domains through DNS and my sites are working....for the most part. The problem is I keep getting emails from the sever every morning, around the same time, with the following...

    httpd failed @ Thu Oct 8 08:52:42 2009. A restart was attempted automagically.
    Service Check Method: [tcp connect]

    Failure Reason: Unable to connect to port 80

    A few times my sites have been knocked down, but not all the time when I get these emails.

    Can anyone help me or point me the right direction with how to diagnose this. It is driving me crazy. Thanks, Brian
     
  2. 9techs

    9techs Member

    Joined:
    Oct 10, 2009
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Please confirm that, your server is not exceeding number of allowed connections.

    Check apache error logs
    grep MaxClients /usr/local/apache/logs/error_log
     
  3. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    If I had to guess your server is overloading at that time, have you ever logged in around then to see what is going on?
     
  4. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    thanks for responses. A few errors I found around the times I got the emails.

    [Tue Nov 03 09:25:42 2009] [error] [client 68.115.132.98] PHP Fatal error: Out of memory (allocated 10223616) (tried to allocate 4864 bytes) in /home/golauren/public_html/libraries/joomla/utilities/simplexml.php(305) : eval()'d code on line 1

    [Tue Nov 03 09:37:04 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Tue Nov 03 09:37:04 2009] [notice] Apache/2.2.13 (Unix) mod_ssl/2.2.13 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.11 configured -- resuming normal operations

    As you can tell I have a joomla installation on this server. I think it has something to do with that.
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might try disabling a few of your Joomla plugins over night to see if that's the cause of the problems.
     
  6. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I tried looking in the file mentioned and all kinds of other files but can't find the Max Clients setting!! Here is my server setup. Can anyone help please.

    cPanel 11.24.5-S38506 - WHM 11.24.2 - X 3.9
    FEDORA 7 i686 virtuozzo on ip-97-74-243-82
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    That's an Apache setting. IMHO, I wouldn't go that route to make the site work. I'd look at what plugin or mod is causing the problem. Multiple results at google concerning this error you might want to investigate further.
     
  8. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    thanks for the response. I looked at the google search you sent and have been trying to find the plugin that is causing the problem but with no luck. In fact, the problem is getting worse. The last two days I have received multiple emails all at the same time for the following services:

    named,
    spamd,
    tailwatchd,
    cpsrvd,
    exim

    Man this is getting frustrating!!

    Where can I go from here???
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    As mentioned previously, you mght try disabling any 3rd party plugins you have installed on the site overnight to see what happens. There is a list of vulnerable Joomla Extensions you might check against whatever you have installed located here: Vulnerable Extensions List oct - Joomla! Documentation

    If you don't have CSF installed, you should.
    ConfigServer Security & Firewall

    It will let you know in more details when something starts to run out of control, and can be configured to kill it if need be.
     
  10. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I restarted the server and got this in /var/log/messages

    I am having a hard time finding all the error logs. Where would I go to see the errors with the named service?

    Sorry if these are real newbie questions but like I said I'm just getting started with running my own server!

    adminalert: Psionic PortSentry 1.1 is starting.
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24237]: adminalert: Going into listen mode on TCP port: 1
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24237]: adminalert: Going into listen mode on TCP port: 111
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24237]: adminalert: PortSentry is now active and listening.
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24238]: adminalert: Psionic PortSentry 1.1 is starting.
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24240]: adminalert: ERROR: No UDP ports supplied in config file. Aborting
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24240]: adminalert: ERROR: could not go into PortSentry mode. Shutting down.
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24240]: securityalert: Psionic PortSentry is shutting down
    Nov 6 14:18:07 ip-97-74-243-82 portsentry[24240]: adminalert: Psionic PortSentry is shutting down
    Nov 6 14:18:07 ip-97-74-243-82 init: no more processes left in this runlevel
    Nov 6 14:18:08 ip-97-74-243-82 named[24341]: starting BIND 9.4.2 -u named
     
  11. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I found the following in my messages log. I have DNS setup so why is it saying I have no A record for golaurens.com?

    Nov 11 08:12:04 ip-97-74-243-82 named[9942]: shutting down
    Nov 11 08:12:04 ip-97-74-243-82 named[9942]: stopping command channel on 127.0.0.1#953
    Nov 11 08:12:04 ip-97-74-243-82 named[9942]: no longer listening on 127.0.0.1#53
    Nov 11 08:12:05 ip-97-74-243-82 named[9942]: no longer listening on 97.74.243.176#53
    Nov 11 08:12:05 ip-97-74-243-82 named[9942]: no longer listening on 97.74.243.82#53
    Nov 11 08:12:05 ip-97-74-243-82 named[9942]: exiting
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: starting BIND 9.4.2 -u named
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: found 8 CPUs, using 8 worker threads
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: loading configuration from '/etc/named.conf'
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: listening on IPv4 interface lo, 127.0.0.1#53
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: listening on IPv4 interface lo:1, 97.74.243.176#53
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: listening on IPv4 interface eth0, 97.74.243.82#53
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 127.IN-ADDR.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 254.169.IN-ADDR.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: D.F.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 8.E.F.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: 9.E.F.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: A.E.F.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: automatic empty zone: B.E.F.IP6.ARPA
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: command channel listening on 127.0.0.1#953
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: zone goclinton.com/IN: loaded serial 2009110402
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: zone golaurens.com/IN: NS 'ns1.golaurens.com' has no address records (A or AAAA)
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: zone golaurens.com/IN: NS 'ns2.golaurens.com' has no address records (A or AAAA)
    Nov 11 08:15:24 ip-97-74-243-82 named[12261]: zone golaurens.com/IN: loaded serial 2009110409
    Nov 11 08:15:25 ip-97-74-243-82 named[12261]: zone smittyapparel.com/IN: loaded serial 2009110604
    Nov 11 08:15:25 ip-97-74-243-82 named[12261]: zone smittymanufacturing.com/IN: loaded serial 2009110601
    Nov 11 08:15:25 ip-97-74-243-82 named[12261]: zone smittyofficialsapparel.com/IN: loaded serial 2009110601
    Nov 11 08:15:25 ip-97-74-243-82 named[12261]: zone goclintonbeta.info/IN: loaded serial 2009111002
    Nov 11 08:15:25 ip-97-74-243-82 named[12261]: running
     
  12. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    The message is referring to missing address or "A" records of the two sub-domains that represent your DNS/name servers, as re-listed below per the provided log detail:
    ns1.golaurens.com
    ns2.golaurens.com

    To correct the issue, edit the DNS zone by adding a new "A" record for each of the two sub-domains "ns1" and "ns2" so that they point to the same IP that is registered at the domain registrar for each DNS/name server. Please note that the two "NS" or "name server" type records should be preserved unless you need to change the name servers to a different set (e.g., to a set of name servers that might already be setup or configured).

    The following menu path in WHM may be used to edit a DNS zone:
    WHM: Main >> DNS Functions >> Edit DNS Zone
    Documentation: EditZone < AllDocumentation/WHMDocs < TWiki

    If the two DNS/name servers are the main set for the server, then it is also be possible to create the A records via the following area in WHM:
    WHM: Main >> Server Configuration >> Basic cPanel/WHM Setup >> Nameservers
    Documentation: BasicSetup < AllDocumentation/WHMDocs < TWiki

    On above page named "Basic cPanel/WHM Setup" there is a section for the name servers; in this section there is a feature for each configured DNS/name server to either "Assign IP Address" or "Add an A entry for this nameserver" -- these may be used as an alternative to or in addition to using the "Edit DNS Zone" function.
     
  13. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Guys, I am posting a screen capture of my dns settings in cpanel. Please take a look and let me know what you think. I added the A entries. Now I can get there through golaurens.com but not GoLaurens.com. Same with most of my customers. This is driving me insane to say the least!!! I am also seeing all kinds of 400.shtnl and 405 errors in my apache logs.
     
    #13 brforte, Nov 12, 2009
    Last edited: Nov 13, 2009
  14. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Both work for me. www. and without. You might just have to wait for propagation a bit longer on your end.
     
  15. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I confirm the same results where the web site loads via both the domain and sub-domain, that is, it loads for me with and without the "www." sub-domain.

    Please ensure to allow at least a full 24 hours for DNS propagation to occur starting from the last edit of the DNS zone.
     
  16. brforte

    brforte Member

    Joined:
    Oct 9, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks guys! The A records for the nameservers were the problem and it did need to propogate for everyone after I made the changes. The sites are back up. I am still getting a couple httpd failures each day. So I will contiune to look into that and will probably be asking for some more help.

    Thanks!
     
Loading...

Share This Page