The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd error

Discussion in 'General Discussion' started by tostrye, Apr 5, 2011.

  1. tostrye

    tostrye Member

    Joined:
    Mar 8, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I have the following error emailed to me and none of my websites work!

    httpd failed @ Tue Apr 5 02:46:02 2011. A restart was attempted automagically.
    Service Check Method: [tcp connect]

    Failure Reason: Unable to connect to port 80

    what does it mean and how can i fix it?
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    There are many possible reasons for Apache to have failed. Do you see an error when you run the following command?

    # /scripts/restartsrv_httpd

    Because there are so many possible reasons for this problem, it is very difficult for us to speculate and find the cause via a forum in a timely manner. Please submit a ticket so that we may log into your server directly, find and fix the problem, and put your sites back online.

    Tickets submitted due to a service down, such as in this case, are given emergency status and are treated with priority until that service is back online.
     
  3. tostrye

    tostrye Member

    Joined:
    Mar 8, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I found the answer by searching. Apache had too many connections, so all I needed to do was a simple Apache restart. Everything is online.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If Apache had too many connections, you may want to check if it was hitting MaxClients:

    Code:
    grep -i maxclient /usr/local/apache/logs/error_log
    If it was hitting that setting, you could increase MaxClients and ServerLimit in WHM > Apache Configuration > Global Configuration area.
     
Loading...

Share This Page