The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd failed

Discussion in 'General Discussion' started by free-admin, Sep 27, 2009.

  1. free-admin

    free-admin Member

    Joined:
    Jan 16, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I installed Cpanel and Litespeed on my server.
    I've just adjusted it and it is new.
    At first "Service Status" showed that httpd service was up but when I moved a client from another server via "Copy an account from another server" and script installed
    SSL Certificate:
    Restoring SSL Vhost
    Waiting for httpd to restart..............finished. httpd (lshttpd) running as root with PID 9111 httpd (httpd (lscgid)) running as root with PID 9112 httpd: [ != HTTP/1..] httpd has failed, please contact the sysadmin. Certificate verification passed

    The Certificate for the domain xxxxxxxxxxxxxxxx.com was installed on the IP xxx.xxx.xxx.xxx
    Finished Install Process.. Certificate successfully installed

    The Certificate was installed but now "Service Status" shows that httpd failed.
    Does anybody come across such a problem? Please help.
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    If you have an SSH access, you can try to fire below commands and check it:

    /scripts/upcp --force
    /scripts/fixeverything
    /scripts/updatenow
     
  3. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    This is an unsupported configuration!

    (And incidentally a VERY BAD idea! :rolleyes: )
     
  4. free-admin

    free-admin Member

    Joined:
    Jan 16, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I made all the commands and http is still failed.
     
  5. free-admin

    free-admin Member

    Joined:
    Jan 16, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    My chkservd.log:

    Service Check Started
    [2009-09-27 16:48:49 UTC] Service check ....syslogd [[check command:+][tcp connect:N/A]]...sshd [[check command:+][tcp connect:N/A]]...pop [[check command:N/
    A][tcp connect:+]]...named [[check command:+][tcp connect:N/A]]...mysql [[check command:+][tcp connect:N/A]]...mailscanner [[check command:+][tcp connect:N/A
    ]]...lfd [[check command:+][tcp connect:N/A]]...imap [[check command:+][tcp connect:+]]...httpd [Service check failed to completehttpd: [ != HTTP/1..]
    [check command:N/A][tcp connect:-]Restarting httpd....
    ]...exim [[check command:+][tcp connect:+]]...cpsrvd [[check command:N/A][tcp connect:+]]...clamav [[check command:+][tcp connect:N/A]]...Done
    Service Check Finished
     
  6. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    I would re-install Cpanel correctly along with Apache 2.2.13 if I were you. ;)
     
  7. free-admin

    free-admin Member

    Joined:
    Jan 16, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    The file chkservd.log shows us that check method has changed:
    before the problem appeared the script checked httpd like this:

    httpd [[check command:N/A][tcp connect:+]]

    and now it checks like this:

    httpd [Service check failed to completehttpd: [ != HTTP/1..]
    [check command:N/A][tcp connect:-]Restarting httpd....

    I think we can resolve the problem if we change the check method to the previous one. And then we'll need to find a file to record necessary settings.
     
  8. votethehost.com

    votethehost.com Active Member

    Joined:
    Oct 2, 2009
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chicago
    httpd started failing after moving an account to the server, I would first check if somewhere any IP's are conflicting in virtualhost entry or not. Give it a try.
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Try removing the client's account entirely (the one you copied over from another server), then set up a new account instead for that client. Another thread on cPanel forum shows a similar issue starting to happen for someone who chose to run lighttpd rather than Apache as well (the error being httpd: [ != HTTP/1..]).

    Of note, cPanel doesn't support litespeed installation in place of Apache on a server as has already been stated here, so copying an account from a server running Apache + cPanel (if that is what the server was running) to your specially setup server and trying to unpackage it there was possibly not advisable.
     
Loading...

Share This Page