The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd failed

Discussion in 'General Discussion' started by Lestat, Nov 16, 2007.

  1. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    I receive about 3-8 emails a day regarding the httpd has failed. I just upgraded 2 days ago to the newest apache and php. What has happened? Is there any one aware on how to fix this?
     
  2. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    /usr/local/apache/logs/error_log
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:04 2007] [emerg] (43)Identifier removed: couldn't grab the accept mutex
    [Wed Nov 14 15:40:05 2007] [emerg] (22)Invalid argument: couldn't release the accept mutex
    [Wed Nov 14 15:40:05 2007] [alert] Child 5817 returned a Fatal error... Apache is exiting!
    [Wed Nov 14 15:40:09 2007] [emerg] (22)Invalid argument: couldn't grab the accept mutex
    [Wed Nov 14 15:40:12 2007] [emerg] (22)Invalid argument: couldn't grab the accept mutex
    [Wed Nov 14 15:44:10 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Wed Nov 14 15:44:10 2007] [notice] ModSecurity for Apache 2.1.3 configured
    [Wed Nov 14 15:44:11 2007] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 28 bytes)
    [Wed Nov 14 15:44:11 2007] [notice] mod_bw : Version 0.8 - Initialized [0 Confs]
    [Wed Nov 14 15:44:11 2007] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Wed Nov 14 15:44:11 2007] [notice] Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.7a mod_bwlimited/1.4 mod_auth_passthrough/2.1 FrontPage/5.0.2.2635 configured -- resuming normal operations



    My httpd crashes about every 2-3 hours..... not sure what is causing it..
     
  3. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    Still happening any ideas?
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Might want to put in a trouble ticket.
     
  5. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    This might not be of much help but I had a similar problem once and recompiling Apache (EasyApache) fixed it.
     
Loading...

Share This Page