The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Httpd fails to start after edge update.

Discussion in 'General Discussion' started by kemraj, Jun 19, 2017.

  1. kemraj

    kemraj Member

    Joined:
    Dec 2, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Tabaquite, Trinidad and Tobago
    cPanel Access Level:
    Website Owner
    Good night guys, as of 1:03 am this morning i've started to get failed httpd emails for no reason. I would like to believe its the Cpanel edge updates.


    This is the error emails i get:

    Service Name

    httpd
    Service Status failed
    Notification The service “httpd” appears to be down.
    Service Check Method The system failed to connect to this service’s TCP/IP port.
    Reason Service check failed to complete
    Unable to connect to port 80 on 127.0.0.1: Connection refused: Died
    Number of Restart Attempts 1
    Startup Log No startup log



    This is when i try to restart apache via ssh.

    Starting httpd: AH00526: Syntax error on line 1050 of /etc/apache2/conf/httpd.co nf:
    SSLCACertificateFile: file '/var/cpanel/ssl/installed/cabundles/cPanel_Inc__6819 17bfb43af6b642178607e0b36ccc_1747526399.cabundle' does not exist or is empty
     
    #1 kemraj, Jun 19, 2017
    Last edited by a moderator: Jun 20, 2017
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,405
    Likes Received:
    53
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    The error suggests that it is because of the SSL certificate that is not identifiable by the Apache, therefore failing to start. Check what SSL it is and reinstall that SSL.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,296
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you confirm that your system was updated to cPanel version 65.9999.180 (the latest EDGE build)? If so, keep in mind the EDGE build tier is not intended for production systems. Here's one potential change that's possibly related to the issue:

    Fixed case CPANEL-13898: Ensure removing a certificate does not fail to remove unused CABs.

    Would you mind opening a support ticket using the link in my signature so we can take a closer look at the affected system to see what happened?

    Thank you.
     
  4. kemraj

    kemraj Member

    Joined:
    Dec 2, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Tabaquite, Trinidad and Tobago
    cPanel Access Level:
    Website Owner
    I had to remove all the ssl certs and Re install them, its appears that the one of the edge released causes an issue with the certs. Some of the ssl certs took forever to validate so i had to install letsencript and it worked.
     
Loading...

Share This Page