The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd has failed, please contact the sysadmin.

Discussion in 'General Discussion' started by jaja123, Jul 28, 2009.

  1. jaja123

    jaja123 Registered

    Joined:
    Jul 28, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    In WHM this is what I get when trying to restart my Apache service:

    When I try to do a EasyApache Update I get this:

    Although, when I look in the error_log, it's empty.

    When I try to see the Apache status I get this:

    So, I've tried to run the httpd configtest. All I got was:

    root@**** [~]# cd /etc/httpd/bin/
    -bash: cd: /etc/httpd/bin/: No such file or directory


    Can't even enter the /bin folder to do a configtest.

    I have tried to search google for hours. I have tried everything. Help me PLEASE!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,469
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Try running this command as root;

    service httpd configtest


    You might want to put in a ticket with your provider or cPanel support.
     
  3. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Try updating your cpanel and restart httpd.

    /scripts/upcp --force
     
  4. jaja123

    jaja123 Registered

    Joined:
    Jul 28, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    When I do that:

    root@**** [~]# service httpd configtest
    /usr/sbin/apachectl: line 97: /usr/sbin/httpd: No such file or directory
    root@**** [~]#

    When I did this:
    This came:
    Code:
    perlmods complete
    
    mysqlcleanup
    mysqlcleanup complete
    0users..........Done
    antirelayd..........Done
    apache.............
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    ........
    Done
    bandmin-pass..........Done
    boxtrapper..........Done
    bsd5..........Done
    chkservdsetup.....Done
    chshsecurity..........Done
    conf.....Done
    cpupdatepatcher..........Done
    defaultsuspendpage..........Done
    defpage..........Done
    eximup.....Done
    filelinkcheck..........Done
    formmail..........Done
    frontpagesec.....Done
    ftpsec..........Done
    gd.....Done
    imap..........Done
    init..........Done
    interchange..........Done
    ipaliases..........Done
    iptables..........Done
    libintl..........Done
    mailman.....Done
    nativedf..........Done
    nativessl..........Done
    neomail..........Done
    newemail.............
    ........
    ........
    Done
    noshell..........Done
    parkeddomainsv2..........Done
    pear-XMLRPC.....Done
    perm..........Done
    phpsanitycheck.....Done
    phpversion..........Done
    pkgfix..........Done
    postmasteralias..........Done
    proftpd.............
    ........
    Done
    putty..........Done
    python..........Done
    re2c..........Done
    rrdtool.....Done
    securitycheck.....Done
    servicedefaults..........Done
    smartmon..........Done
    spam3..........Done
    sqllimit..........Done
    static-stunnel.............
    ........
    ........
    Done
    statmanager..........Done
    stunnelkey..........Done
    uncache..........Done
    update..........Done
    vfilters..........Done
    webalizer-rh8compat..........Done
    webmail.............
    ........
    Done
    wheelsu..........Done
    zonetemplates..........Done
    Final Post Install...........
    ........
    ........
    Done
    
    ==> cPanel Install Complete
    ==> Removing Installer.....Done
    ==> Starting cPanel....
    Waiting for cpaneld to shutdown ... ...Done
    Waiting for webmaild to shutdown ... ...Done
    Waiting for cphulkd.pl to shutdown ... ...Done
    Waiting for cPhulkd to shutdown ... ...Done
    Waiting for cphulkd to shutdown ... ...Done
    [Tue Jul 28 08:53:36 2009] Current process '10550' stopped
    Waiting for cpdavd to shutdown ... ...Done
    Waiting for cpdavd-ssl to shutdown ... ...Done
    Waiting for cpdavd-ssl to shutdown ... ...Done
    Waiting for cpldapd to shutdown ... ...Done
    Waiting for cppop to shutdown ... ...Done
    Waiting for cppop-ssl to shutdown ... ...Done
    Waiting for cpanellogd to shutdown ... ...Done
    Waiting for entropychat to shutdown ... ...Done
    Waiting for eximstats to shutdown ... ...Done
    Waiting for melange to shutdown ... ...Done
    Waiting for startmelange to shutdown ... ...Done
    PID unreadable in: /usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid
    [Errno 2] No such file or directory: '/usr/local/cpanel/3rdparty/mailman/data/ma                                                                             ster-qrunner.pid'
    Is qrunner even running?
    Shutting down Mailman's master qrunner
    mailmanctl: no process killed
    Waiting for antirelayd to shutdown ... ...Done
    Waiting for eximstats to shutdown ... ...Done
    Waiting for cpbandwd to shutdown ... ...Done
    2009-07-28 12:53:40 UTC [main] Current process '10523' stopped
    Waiting for tailwatchd to shutdown ... ...Done
    Waiting for cpsrvd to shutdown ... ...Done
    Waiting for cpsrvd-ssl to shutdown ... ........... terminating cpsrvd-ssl .....D                                                                             one
    Waiting for whostmgrd to shutdown ... ...Done
    ==> cPanel Log Daemon version 24.0
    Waiting for cppop to shutdown ... ...Done
    Waiting for cppop-ssl to shutdown ... ...Done
    [Tue Jul 28 08:53:51 2009] Starting /usr/local/cpanel/bin/tailwatchd daemon
    Log is at /usr/local/cpanel/logs/tailwatchd_log
    ==> Post Install Complete
    
    Broadcast message from root (Tue Jul 28 08:53:53 2009):
    
    cPanel Layer 2 Install Complete
    ...Done
    Updating Addons...Warning: language cache is out of date.  It is being rebuilt n                                                                             ow.
    Can't locate Class/Std.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib64/p                                                                             erl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.7/                                                                             x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-m                                                                             ulti /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/s                                                                             ite_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /us                                                                             r/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_per                                                                             l/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linu                                                                             x-thread-multi /usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi /usr                                                                             /lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_p                                                                             erl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr                                                                             /lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x                                                                             86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/local/cpanel/Cpanel/Lan                                                                             g/Cache/Utils.pm line 12.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Lang/Cache/Utils.p                                                                             m line 12.
    Compilation failed in require at (eval 1) line 3.
            ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Lang/Cache/Utils/C                                                                             achelangfiles.pm line 14.
    Compilation failed in require at /usr/local/cpanel/bin/cachelangfiles line 11.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cachelangfiles line 1                                                                             1.
    ...Done
    Running postinstall scripts...Added Contact contact@bpbux.com
    Scanning for new mail senders.....Done
    Scanning suexec_log...Done
    ...Done
    
     
  5. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Did you try restarting httpd now?
     
  6. jaja123

    jaja123 Registered

    Joined:
    Jul 28, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Doesn't work.
     
  7. wanga

    wanga Registered

    Joined:
    Apr 5, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    same problem here on a 64bit rhel 5.3 box.
     
  8. wanga

    wanga Registered

    Joined:
    Apr 5, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1


    do this:

    1. /scripts/cleanversion
    2. /scripts/perlinstaller --force Class::Std
    3. /scripts/upcp --force

    should fix it
     
Loading...

Share This Page