httpd.pid not readable after start

xata11

Member
Oct 17, 2018
14
0
1
Port harcourt
cPanel Access Level
Root Administrator
I have similar Problem to this... when I try to restart Apache. and my site goes now by it self, and come up after 1 hour...

/scripts/restartsrv_apache
Waiting for “httpd” to restart gracefully …waiting for “httpd” to initialize ………finished.

Service Status
httpd (/usr/sbin/httpd -k start) is running as root with PID 2665 (systemd+/proc check method).
httpd (/usr/sbin/httpd -k start) is running as nobody with PID 20858 (systemd+/proc check method).
httpd (/usr/sbin/httpd -k start) is running as nobody with PID 21261 (systemd+/proc check method).
httpd (/usr/sbin/httpd -k start) is running as nobody with PID 21267 (systemd+/proc check method).
httpd (/usr/sbin/httpd -k start) is running as nobody with PID 21276 (systemd+/proc check method).
httpd (/usr/sbin/httpd -k start) is running as nobody with PID 21526 (systemd+/proc check method).

Startup Log
Jan 05 22:36:19 vmi19532.server.net systemd[1]: Starting Apache web server managed by cPanel EasyApache...
Jan 05 22:36:21 vmi19532.server.net systemd[1]: PID file /run/apache2/httpd.pid not readable (yet?) after start.
Jan 05 22:36:21 vmi19532.server.net systemd[1]: Started Apache web server managed by cPanel EasyApache.
Jan 05 23:37:54 vmi19532.server.net mod_evasive[5344]: Blacklisting address 162.158.xxx.xxx: possible DoS attack.
Jan 05 23:37:56 vmi19532.server.net mod_evasive[2696]: Blacklisting address 162.158.xxx.xxx: possible DoS attack.
Jan 06 05:08:20 vmi19532.server.net mod_evasive[19461]: Blacklisting address 172.69.xxx.xxx: possible DoS attack.
Jan 06 05:09:09 vmi19532.server.net mod_evasive[19646]: Blacklisting address 108.162.xxx.xxx: possible DoS attack.
Jan 06 06:00:26 vmi19532.server.net mod_evasive[25148]: Blacklisting address 108.162.xxx.xxx: possible DoS attack.

Log Messages
[Sun Jan 06 08:26:50.145858 2019] [mpm_prefork:notice] [pid 2665] AH00163: Apache/2.4.37 (cPanel) OpenSSL/1.0.2p mod_bwlimited/1.4 configured -- resuming normal operations
[Sun Jan 06 08:05:35.277258 2019] [mpm_prefork:notice] [pid 2665] AH00163: Apache/2.4.37 (cPanel) OpenSSL/1.0.2p mod_bwlimited/1.4 configured -- resuming normal operations
[Sun Jan 06 07:53:54.635680 2019] [mpm_prefork:notice] [pid 2665] AH00163: Apache/2.4.37 (cPanel) OpenSSL/1.0.2p mod_bwlimited/1.4 configured -- resuming normal operations
[Sun Jan 06 07:04:05.651070 2019] [mpm_prefork:notice] [pid 2665] AH00163: Apache/2.4.37 (cPanel) OpenSSL/1.0.2p mod_bwlimited/1.4 configured -- resuming normal operations
[Sun Jan 06 06:08:49.419403 2019] [mpm_prefork:notice] [pid 2665] AH00163: Apache/2.4.37 (cPanel) OpenSSL/1.0.2p mod_bwlimited/1.4 configured -- resuming normal operations

httpd restarted successfully.
 

xata11

Member
Oct 17, 2018
14
0
1
Port harcourt
cPanel Access Level
Root Administrator
Hello @xata11

Is anything noted in the apache error log during the timeframe the issue occurs?

Code:
/etc/apache2/logs/error_log
the issue has been fixed, it seems mod_evasive is blocking cloudflare ip which hit heavily on my server, so I disable mod_evasive and increased php-fpm pool size from 5 to 10, the only problem I am having now Is bots that as heavily hitting me, and I cannot block their IP since I am connected to cloudflare, I only get to see cloudflare IP(s) instead of the bot IP when I checked on my apache log, especially SemrushBot.
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,012
648
263
Houston
cPanel Access Level
DataCenter Provider
Hi @xata11

That would do it! You might want to check CloudFlare's IP ranges and add them in mod_evasives whitelist - if you want to continue using it. Also in regard to the bot traffic, you might want to look into mod_remoteip which once configured will allow for the correct IP to be shown.

At one point CloudFlare had the mod_cloudflare plugin that did this but they've since deprecated it in favor of mod_remoteip.


Thanks!