The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd problems, please help

Discussion in 'General Discussion' started by papa2ae, Apr 6, 2009.

  1. papa2ae

    papa2ae Registered

    Joined:
    Apr 6, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello guys,

    this is a fresh install on centos.5 (vps)

    after installing cpanel and restarting the vps and doing all the setup in the cpanel, when i try to restart cpanel i get an error of FAIL after automagically restarting.

    So i went into SSH, and i did service httpd start, i get this error ...

    Code:
    Starting httpd: /bin/bash: /usr/sbin/httpd: No such file or directory
                                                               [FAILED]
    I dont get it :S - why is this happening?

    Please tell me how to fix this.

    regards,
    papa2ae
     
    #1 papa2ae, Apr 6, 2009
    Last edited: Apr 6, 2009
  2. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    Seems that the httpd startup script is old one and not updated with the Apache installed by cPanel. You can try replacing it with the cPanel Apache startup script as:

    mv /etc/init.d/httpd /etc/init.d/httpd.old
    cp /usr/local/apache/bin/apachectl /etc/init.d/httpd
    /etc/init.d/httpd restart
     
Loading...

Share This Page