The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd segmentation fault

Discussion in 'General Discussion' started by tratti, Apr 18, 2007.

  1. tratti

    tratti Active Member

    Joined:
    Nov 8, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    after an installation of mysql 5.0.27, apache (1.3.37) every hour crash...
    this is the error_log
    [Wed Apr 18 13:22:04 2007] [notice] child pid 2586 exit signal Segmentation fault (11)
    [Wed Apr 18 13:54:41 2007] [notice] child pid 3921 exit signal Segmentation fault (11)
    [Wed Apr 18 13:54:42 2007] [notice] child pid 2609 exit signal Segmentation fault (11)
    [Wed Apr 18 13:54:42 2007] [notice] child pid 10807 exit signal Segmentation fault (11)
    [Wed Apr 18 14:37:53 2007] [notice] child pid 10572 exit signal Segmentation fault (11)
    i've tried to upgrade php and now i've installed php 5.2.1

    then i upgrade cp...
    and finally i upgrade cp to edge version...
    but without any result..

    i cannot reinstall apache because easyapache give me a strange error
    undefined reference to `log_config_module'
     
  2. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Do you have an old version of Zend Optimizer running at all? Make sure if you use the latest PHP version that Zend is at least 3.22
     
  3. tratti

    tratti Active Member

    Joined:
    Nov 8, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    i've upgrade to 3.2.2 without any results...
    any other suggestion?
     
  4. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    [urgent]

    same problem, any solution for:
    ed May 23 11:45:48 2007] [notice] child pid 10332 exit signal Segmentation fault (11)
    [Wed May 23 11:45:48 2007] [notice] child pid 10333 exit signal Segmentation fault (11)
    [Wed May 23 11:45:48 2007] [notice] child pid 10334 exit signal Segmentation fault (11)
    [Wed May 23 11:45:49 2007] [notice] child pid 10337 exit signal Segmentation fault (11)
    [Wed May 23 11:45:49 2007] [notice] child pid 10338 exit signal Segmentation fault (11)
    [Wed May 23 11:45:51 2007] [notice] child pid 10342 exit signal Segmentation fault (11)
    [Wed May 23 11:45:51 2007] [notice] child pid 10343 exit signal Segmentation fault (11)
    [Wed May 23 11:45:51 2007] [notice] child pid 10344 exit signal Segmentation fault (11)

    ?

    PHP 5.2.0 (cli) (built: May 23 2007 11:35:49)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
    with the ionCube PHP Loader v3.1.29, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.2.2, Copyright (c) 1998-2006, by Zend Technologies

    mysql Ver 14.7 Distrib 4.1.21, for pc-linux-gnu (i686) using readline 4.3
     
    #4 lehels, May 23, 2007
    Last edited: May 23, 2007
  5. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    It can be either due to the corrupt PHP or Zend Optimizer. Firstly try disabling the Zend Optimizer in /usr/local/Zend/etc/php.ini and see how it goes. If you still see that same error then go for php recompile using /scripts/easyapache.
     
  6. plague

    plague Active Member

    Joined:
    Sep 22, 2006
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brasil
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi

    I have a customer that have modernbill running in his account with a payment system. With Zend Optimizer enabled, MB works fine, but the payment system don't (Segmentation fault (11) error in apache error_log when we access the page). If I disable the Zend Optimizer in php.ini, the payment system works fine, but the MB requires Zend to run ¬¬'

    I have recompiled Apache many times, with different configurations. I have another server running the same system, and it's running fine. I try the same config in the server with this issue, but without success.

    I'll try to modify the Zend version
     
  7. plague

    plague Active Member

    Joined:
    Sep 22, 2006
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brasil
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello

    The old version of Zend Optimizer (3.2.2) was still in the server.

    Changing the version of Zend in php.ini (3.3.0 to 3.2.2) solved the problem ;D
     
  8. fenixer

    fenixer Well-Known Member

    Joined:
    Feb 23, 2007
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Hello...

    In my case, php 4.4.7 + Zend O. 3.3.0 did wrong... several sites down because of segmentation faults...

    It only ocurrs in one server (i have more phps 4.4.7 with last zend running without problems), but today i have recompiled apache for 8 times, updated cpanel, recompiled again, and finally discovered it was Zend fucking me...

    Now, it is not possible to "select" the Zend version by editing /scripts/installzendopt...

    Is there any way to select by example 3.2.6 version of Zend to install???????????

    Thanks.
     
  9. fenixer

    fenixer Well-Known Member

    Joined:
    Feb 23, 2007
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    no way????? version 3.2.6 of Zend Opt. is super-stable with php 4.4.x...

    The scripts of cpanel does not allow to select the version of the module? (i have been checking the scripts and I guess no)
     
  10. plague

    plague Active Member

    Joined:
    Sep 22, 2006
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brasil
    cPanel Access Level:
    Root Administrator
    Twitter:
    I don't know any way to select the version of Zend in the install script.

    I think the only way is download the files(or scp the files from your other servers) and editing the php.ini manually to call Zend 3.2.6.
     
  11. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The phpextensionmanager script will install Zend Opt 3.2.8 for PHP 4
     
Loading...

Share This Page