The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd vs SSL

Discussion in 'General Discussion' started by Cooler-Ua, Jan 30, 2007.

  1. Cooler-Ua

    Cooler-Ua Registered

    Joined:
    Jan 23, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi ppl!

    I have a trouble.

    I have a SSL certificate. It`s normally install from WHM, but when I`m try to connect on domain httpd dosn`t listning 443 port (default).

    php was recompiled. SSL was enabled in it. Apache was recompiled. SSL was enabled in it.

    But when I starting httpd:

    Code:
    root@uran [/]# /usr/local/apache/bin/apachectl start
    [Wed Jan 31 03:31:51 2007] [warn] NameVirtualHost **.**.***.***:80 has no VirtualHosts
    [Wed Jan 31 03:31:51 2007] [warn] NameVirtualHost **.**.***.***:80 has no VirtualHosts
    /usr/local/apache/bin/apachectl start: httpd started
    root@uran [/]# ps waux | grep http
    root     29161 53.5  1.0  97712 20964 ?        Ss   03:31   0:01 /usr/local/apache/bin/httpd
    nobody   29165  1.0  0.9  97736 19544 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29166  0.0  0.9  97712 18872 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29167  0.0  0.8  97712 18572 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29168  0.0  0.8  97712 18572 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29169  0.0  0.8  97712 18140 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29170  0.0  0.8  97712 18140 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29171  0.0  0.8  97712 18140 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29172  0.0  0.8  97712 18140 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29173  0.0  0.8  97712 18140 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29174  0.0  0.8  97712 18140 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    nobody   29177  0.0  0.8  97712 18144 ?        S    03:31   0:00 /usr/local/apache/bin/httpd
    root     29183  0.0  0.0   1692   536 pts/1    S+   03:31   0:00 grep http
    root@uran [/]#
    It`s starts whitout -DSSL flag.
    When I`m starting it whith
    /usr/local/apache/bin/apachectl startssl
    httpd doesn`t starts at all.

    In logs only:
    Code:
    [Wed Jan 24 18:52:57 2007] [error] mod_ssl: Init: (domain.net:443) Unable to configure verify locations for client authentication
    Code:
    # netstat -an | grep 443
    #/CODE]
    
    Troble whith my configs or in SSL cert?
    
    [CODE]# uname
    Linux
    #
     
  2. Cooler-Ua

    Cooler-Ua Registered

    Joined:
    Jan 23, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Solved my problem.

    Topic close.
     
Loading...

Share This Page