The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

httpd won't restart, no errors

Discussion in 'General Discussion' started by Zion Ahead, Mar 14, 2007.

  1. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    root@server [~]# service httpd restart
    /etc/init.d/httpd restart: configuration broken, ignoring restart
    /etc/init.d/httpd restart: (run 'apachectl configtest' for details)
    root@server [~]# /usr/local/apache/bin/apachectl configtest
    root@server [~]#


    I can't find the cause of this. I simply installed eaccelerator and updated Zend to 3.2.4

    php.ini


    [Zend]
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.4
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.4
    zend_optimizer.version=3.2.4


    [suhosin]
    extension="/usr/lib/php/suhosin/suhosin.so"
    ;suhosin.version=0.9.16

    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    [eAccelerator]
    zend_extension="/usr/lib/php/eaccelerator/eaccelerator.so"
    eaccelerator.shm_size="4096"
    eaccelerator.cache_dir="/tmp/eaccelerator"
    eaccelerator.enable="1"
    eaccelerator.optimizer="3"
    eaccelerator.check_mtime="1"
    eaccelerator.debug="0"
    eaccelerator.filter=""
    eaccelerator.shm_max="0"
    eaccelerator.shm_ttl="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_only="0"
    eaccelerator.compress="1"
    eaccelerator.compress_level="9"
    eaccelerator.keys="shm_and_disk"
    eaccelerator.sessions="shm_and_disk"
    eaccelerator.content="shm_and_disk"


    What should I do?

    Last thing I see in apache error logs:

    2007-03-14 19:04:29 1HRdSH-0005nE-DS Expansion of ${if !eq {$header_From:}{}{$header_sender:$header_From:}fai l} failed while rewriting: syntax error in "if" item - "fail" expected
     
    #1 Zion Ahead, Mar 14, 2007
    Last edited: Mar 14, 2007
  2. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Fixed.

    I move eaccelerator portion before Zend, restarted apache
     
  3. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Lol I was just going to say that, a big hint on this is that when you run the
    Code:
    # service httpd configtest
    Syntax OK
    #
    
    You should get the "Syntax OK", above you got nothing. We ran into the same thing when adding shared ioncube loaders to the php.ini files.
     
  4. jsnape

    jsnape Well-Known Member

    Joined:
    Mar 11, 2002
    Messages:
    174
    Likes Received:
    0
    Trophy Points:
    16
    We've had it when the httpd.conf file was empty or missing.
     
Loading...

Share This Page