captainron19

Active Member
Nov 10, 2011
33
1
56
cPanel Access Level
Root Administrator
Never really took note of this before but a person with a site on my Dedicated VPS informed me they were concerned that they were getting a notification on browser near address bar saying "Site not Secure" I know it has something to do with all sites operating with http instead of https.

I do have a single SSL certificate for the server itself that I bought and had installed from my provider but how can I have everything set to be https for all sites on my VPS?

I did (out of curiosity try re-typing one of the domains on my server with an https first and the site appeared but all formatting was incorrect I am guessing is has something to do with the site pages having the extension .php because when i tried it on another site on my server with a .html extension the formatting was all correct

Any help would be appreciated
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston

captainron19

Active Member
Nov 10, 2011
33
1
56
cPanel Access Level
Root Administrator
Hello,

The issue is that the site was being viewed over https without an SSL certificate. cPanel offers free 90 day SSL certificates through the AutoSSL feature.

You can also purchase SSL certificates directly from the store if this feature is enabled in WHM for your users.
I do have an SSL (for the reserver) but my hostinf company resolved it by placing some code in the htaccess file and all is good now so it basically re-directs to the https
 

captainron19

Active Member
Nov 10, 2011
33
1
56
cPanel Access Level
Root Administrator
Hello,

The issue is that the site was being viewed over https without an SSL certificate. cPanel offers free 90 day SSL certificates through the AutoSSL feature.

You can also purchase SSL certificates directly from the store if this feature is enabled in WHM for your users.

By the way..... this is the code my hosting provider put in the htaccess file to resolve the situation .....

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]]
 
  • Like
Reactions: cPanelLauren