https for webmail throws 404 error

jp-nyc

Member
Jul 10, 2022
5
0
1
New York
cPanel Access Level
Website Owner
I have a several web sites running on a shared hosted server (I dont have WHM access). Every site except one I can enter in my browser https://webmail.example.com or http://webmail.example.com and they both work and resolve to the secure or insecure pages accordingly.

On the one site the page resolves correctly for regular http but I get a "404 Not found" error when I try https for the webmail subdomain of that site. https://myexample.com does work for all pages on that site (without the webmail subdomain).

All of the DNS settings are the same for all of the sites.
There is a CNAME record webmail.example.com --> example.com.
None of the sites have a "proper" subdomain setup where the subdoman points to a directory, just the DNS setting.
The SSL Status reports that the SSL cert for the webmail subdomain is valid.

Im not sure what else to check or how webmail ultimately get pointed to the webmail page.
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
476
223
118
IN
cPanel Access Level
Root Administrator
As you are on shared hosting, I would suggest you to report this to your hosting provider as they will be able to investigate this further by checking the relevant logs on the server your account is hosted.
 
  • Like
Reactions: cPRex

jp-nyc

Member
Jul 10, 2022
5
0
1
New York
cPanel Access Level
Website Owner
I'm trying to avoid going through them. They always reset or change something that I have configured. I was trying to pinpoint the issue instead of just having them push a button that changes or resets multiple things.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,718
1,862
363
cPanel Access Level
Root Administrator
I'm not sure how you'll be able to resolve this one without poking the host, as the issue seems exclusive to one vhost. There is likely a missing SSL certificate or a problem with the way the SSL is configured for that domain. If you can see this area, you can check cPanel >> SSL/TLS Status to see if webmail.domain.com is one of the areas referenced in the installed SSL certificate. However, if it's not, there isn't anything you can do on the user side to force that to happen if it's not working already.
 

jp-nyc

Member
Jul 10, 2022
5
0
1
New York
cPanel Access Level
Website Owner
There is likely a missing SSL certificate or a problem with the way the SSL is configured for that domain. If you can see this area, you can check cPanel >> SSL/TLS Status to see if webmail.domain.com is one of the areas referenced in the installed SSL certificate.
I have checkd and SSL Status reports that the SSL cert for the webmail subdomain is valid.

What is the actual magic that makes the webmail.example.com point to webmail, since the CNAME record for webmail just points back to example.com?
 

jp-nyc

Member
Jul 10, 2022
5
0
1
New York
cPanel Access Level
Website Owner
I had a look at Service and Proxy Subdomains but it doesnt say where the config files that the GUI creates by enabeling these settings are stored. Are they stored in a location that I can access (such as /.cpanel/nvdata ) or are they stored in a directory that is not accessable by non WHM user?
 

jp-nyc

Member
Jul 10, 2022
5
0
1
New York
cPanel Access Level
Website Owner
Just quick update: I spoke to my host a week ago and I am still waiting for them to fix it. Not hopefull since I never even got an open ticket email!