https not working anymore on port 2087

Paulblo

Member
May 10, 2002
16
0
301
Here is the scoop.

Yesterday I was able to connect to WHM via SSL (https and port 2087) but today it will not connect. The only thing that I can think of that might be the cause is that I re-compiled apache and added the Curl and Curl with SSL support.

Any tips? :)

Thanks,

Paulblo
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
BTW I feel your pain, it seems that changing around apache modules, be it by hand or with a buildscript, can trigger webhost manager from not binding to 2087 and the cpanel secure link not binding to 2083 either.....

It looks like a bigger issue altogether, though probably still related to ssl in some way, shape or form.

Once I figure anything out I will let you know!
if anyone else has a clue please post something (only if it is intelligent)

ahahah :p
 

Paulblo

Member
May 10, 2002
16
0
301
I got it working...

Somehow someway I was able to get it working. I think it was a permission setting. I updates to the most recent cpanel and it accepted a connections on port 2087. :)

Thanks,

Paulblo
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
Mind sharing that permissions tweak?
It might be a bug that is beginning to propogate....

Or I may have just missed something completely.


Thanks.....
 

Paulblo

Member
May 10, 2002
16
0
301
Well I have just gotten a box ready for hosting so I have been trying to lock it down inside and out. Si I changed some permissions on certain diectories so the users with shell access will be very limited as to what they can see. I made some changes to some root directories like /etc/, /sbin/, and stuff so the world would not see the contents. I noticed the SSL problems and then regretted changing all of the directories permissions at one so I changed the permissons for the world to exicute but not read or write. I tested it and it worked. I can't tell you what programs in the sbin were used or needed but I got it working so that is what counts. Sorry I can't be more specific. :)

Paulblo